Stuck trying to reformat SSD

I’ve removed a 240GB SSD Plus from an old laptop that’s being recycled. The SSD was a replacement for the original HDD in the laptop. The SSD was working fine and was the main (C: ) drive in the laptop, so had all the Windows 10 system files on it as well as data and applications.

I’ve connected it to my new laptop to try to reformat it as a plain external drive for data files. Connected with the SATA and USB cable that I used originally to clone the old HDD with.

Windows explorer cannot hold a connection with the SSD and I’m unable to reformat it. In Explorer it shows either as Local Disk (D): or D:\ or System Reserved (D: ). In any case it doesn’t hold the connection long enough for me to right click and execute a format instruction.

I’ve also tried the disk management app in Control Panel, but that doesn’t recognise the SSD at all.

Any pointers the forum can offer?


Is the SSD you use encrypted. It is that if you are not able to gain access to the content on SSD.

Please notify if it solved your problem.