stuck on 'refreshing your media'.

Hi, I just got this yesterday and have had a lot of trouble with it, the software not installing properly, the device not being recognised; it getting stuck on the stage ‘refreshing your media’ - I’ve done a couple of soft resets; but it doesn’t seem to be working. Can anyone help with this?

sorry - didn’t mention that I did uninstall and reinstall the software and it’s still happening.

How long did you wait? It can only appear to be frozen (the progress bar doesn’t really scale correctly to the time it will take to finish). Things that can cause it to take a long time: a large number of files and/or folders, corrupted files, and sloppyID3 tags.

More about tags: when it says “refreshing your media”, what it’s really doing is building a database of all the information in the tags (title, artist, album, track number, etc.). The player can choke on messy tags, particularly very long comments. For some reason, some people try to put the artist’s entire history (or some other ridiculously verbose nonsense) in the “Comment” tag. The best thing to do is to use a progam like MP3Tag (highly recommended, and FREE) to clean up the tags, deleting comments and paring down the other tags to only the essentials. Whatever tag editor you use, change the settings to save tags in ID3 v2.3 ISO 8859-1 format if possible. This format is the most compatible with Sansas.

If your tags are clean and it still freezes up, you probably have a corrupt file. To make it simpler to isolate the problem file(s), format the player (from the Settings>System Settings menu) and start reloading your files in smaller batches until it freezes up again.

Hi, that was very useful, thanks. I downloaded the MP3Tag cleaner, and although everything was pretty clean (no comments at all) there was a lot of info there when you add up all the tags. And when it refreshed this time, it didn’t get stuck.

I’ll save the info about doing the re-format in case I need it.



I dled the Mp3tag program and do not see an option for “cleaning” tags.  Can you tell me where you found that in the program?  My zip is refreshing media each time I unplug it from charging and it takes FOREVER to refresh.  



There’s no general “clean” button on MP3Tag.  To clean via MP3Tag would mean to eliminate info. in tags that is not needed or to strip away long tags, and likewise to convert the tags (if needed) into the ISO type that the Clip will accept.  Many of these tasks can be done viaq batch tasks–that is, to all the files as a whole, rather than 1-by-1.

Too bad there isn’t an

button. :laughing:


I’m getting Refreshing Your Media: Nightmare Level.

I have a Clip Zip with a really persistent case of Refreshing Your Media.  A Macbook was used to load tracks onto it, but then I got the RYM screen so took it to my Windows 7 machine to try to fix.

I’ve tried everything mentioned in the forums, including:

  • Holding the Hold button for 60 seconds to do a reset.
  • Manually updating to firmware 01.01.20A successfully.
  • Connecting to a Windows 7 machine in MSC mode and doing a full format (not quick format), then updating the firmware sucessfully. (i have done this at least 3 times now)
  • formatting the device from within its settings menu
  • Letting it do its Refreshing Media thing for 10-30 minutes, even with no media loaded.

Even with no media loaded on, I get the Refreshing Your Media screen stuck on.  When I force MSC and load on some tracks (clean id3 tags) I can get it to play tracks, but the Refreshing your media loop comes on whenever:

  • the Hold button is the first thing you press after powering on
  • long-press the Hold button to shut down.

It also goes into the Refreshing Your Media loop unpredictably when pressing the Hold button (instead of the lock coming on, I get the Refreshing Your Media).

I have never used an external msd card on this unit.

I have a second, identical Clip Zip with no problems.

Any other ideas, or is this unit toast?

@refreshingmedia wrote:


I have a second, identical Clip Zip with no problems.


Any other ideas, or is this unit toast?


If all things are equal on both players and one works properly and the other doesn’t, I think you’ve answered your own question.

@tapeworm wrote:

If all things are equal on both players and one works properly and the other doesn’t, I think you’ve answered your own question.

Agh. Thanks. I was so frustrated with the process I overlooked the obvious. Toast it is.

I would contact SanDisk’s Customer Service (by telephone is best), for assistance. And if you are under warranty, SanDisk could replace the player.

Bogus link - dump this guy

@rcombes wrote:

Bogus link - dump this guy

What link? What guy? :confounded:

If you are referring to a previous post in this thread, it would help to use the Quote button (top right of message composition pane) so people would know what you are talking about.

I’ve gone back to the beginning of the thread and there’s only 1 post (from someone who’s been around here quite a while and knows what he is talking about) with links in it. The information provided is still valid and the links work just fine.

My Sandisk Sansa Clip+ got stuck on “Refreshing Your Media” after I tried adding a new playlist via Windows Media Player.

I found this solution worked for me:

Download the firmware update:

You basically just download a file, connect the device to your PC, and then copy the file into the root directory of the player’s drive.  Then disconnect the drive, and it will install the firmware update.  After it is done, it will shut off. Then when you turn it on again, you should be good to go.

I assume this solution will work for other models as well.

How I fixed a Sansa Clip+ version 1 that was stuck on the “Refreshing media” screen:

  • Plug into a windows PC via USB
  • Delete all files from the drive root of the Clip+
  • Paste the driver file clppa.bin into the drive root of the Clip+
  • Eject the Clip+ from the Windows PC

This made the device completely wipe clean and working again to play music.

thanks for this info, helped me get my clip working again, this is for the firm ware update a couple messages above.