Stuck in “Refreshing your media” no solution

Last Sunday I started recording voice at a function. I wasable to “pause” the recording, but when I tried to “save” the recording, myFUZE froze in the “Refreshing your media” mode and it has been that way eversince.  I am able to turn it on andoff, ut each time I turn it on, it is still in the “Refreshing your media”mode.  The Reset doesn’t doanything, no matter how long I hold the switch in the off position.  The status bar never starts.  When I plug it into my computer (a Mac)it come on in the “Refreshing your media” mode but is never recognized by thecomputer.  None of the forumsolutions proposed for the following postings worked:

    01-18-2009 11:57 PM by " lukev", titled “** Tired of ‘Refreshing your Media’ and freezing **

    11-13-2008 07:49 AMby “ DXD ”, titled “ Sansa Fuze "Refreshing Your Media"frozen up!

(Putting device in Lock (slide thePower switch to Hold position) and pressing and holding the Rewind buttonas I connect it to my Mac computer does NOT force the Fuze to connect in MSC mode.)

Any other ideas???

That is a very strange occourance. I have never heard of this problem, that couldnt be solved based on the threads you sited. And If you cant force to MSC just confuses things further. If you can get access to a PC try formatting from the PC. If thats not an option call SanDisk they may know what to do.