stuck at "refresing your media"

I have a sansa clip+ with internal 2GB memory and external 16GB memory. since I bought I’ve been sufering from how slow this device is.

sometimes it takes it like hakf a munute to pass to the next song (while on shuffle).

any way… now I think its actualy stuck…

I tuned it one and it says that is refresing media (I don’t even know why, I didn’t make any change) and for two hours its stuck at the begining of the refresh and it won’t budge.

I tried hard reseting it without the extention micro sd and it worked but it keep getting stucke when I use the SD card (I just wan’t to say that the MP3 player used to work with this SD card and its the first time I encounter this problem and I eliminated the option that the card is damaged because I both try the sd card on my celphone and it worked and I tried the sd card of my phone on the MP3 player and encounter the same problem)

can this be solved in any way by me, or should i contact the place where I bought it and demend they replace my sansa clip+ to a one that work properly?


There’s nothing wrong with your player. You have put a file (or files) on it that it cannot read or is having difficulty de-cyphering. Most likely ID3 tag-related but also could be corrupted files.

Are you transferring your files from a PC or a Mac?  A Mac can create “ghost” admin. files that can choke a non-Apple player, camera or other device–a solution is to transfer from the Mac using Internet freeware that will handle this, Hidden Cleaner and KopyMac being 2 prime ones.

how about using it without external memory (m sd hc) did it work properly?