Still getting 90mb over limit message after formatting twice

been using mac osx virtual machine windows xp and regular windows xp…not sure if that’s relevant though. i have the 4gb model

Whats the firmware loaded on your Sansa? If not yet up to date, try updating it.

That message usually means that there is one (or more) corrupted files on the player as explained in this FAQ (the 90mb msg. is the same as the 6mb msg. in the FAQ. It’s just the Fuze’s version). If you format it, and then load up the same files without fixing them first, of course you’re going to get that message again.

tried to install new firmware, but when i hooked up my sansa to a windows XP comp and tried to drag the new firmware file into the directory, got a message saying that i needed to format the device again through the computer (as opposed to going to the settings w/in the fuze)–is this normal? should i go through with it?

you know, if only i was allowed to get as far as uploading files again to my sansa…after reformatting, I still can’t get it to turn on with out the 90mb message, even with -no- files inside. *sigh*

Use forced MSC:

  1. Turn device OFF.
  2. Slide the Hold switch down to Lock (orange color showing).
  3. Press and hold the left button ( |<< ) while connecting the device to the PC.

You can format the device using My Computer this way, then load the firmware after.  Do check which firmware revision is right for your Sansa. There is the version.sdk file inside the device when you open it. Compare the revision number found on the Firmware forum found on this file (you would need to open this file using notepad to view its contents).