Sound quality issues with my Sansa Clip and Rhapsody subscription tracks

I’m at my wits end here. This past Christmas I purchased a Black 4GB Sansa Clip for myself. About two weeks after I bought it I received an error about insufficient memory to create a database. I reformatted the drive, retransferred the songs and everything worked fine… for a week. Then I got the same error message before it died completely. As in it wouldn’t turn on at all, even hooked up to my PC.

I took it back to the place a purchased it from and received a replacement. Now this one won’t play any long Rhapsody subscription tracks without some distortion starting about 13-14 minutes in and continuing to the end of the track.

I did not have this problem with the first Clip.

I do not have this problem with any tracks I’ve ripped and tranferred.

I do not have this problem with my c250.

I DO have this problem with my son’s Silver 4GB Clip. However in addtion to the simple popping I get with my Clip, the music also sounds warped, with major dropouts on his.

I have already done the song and dance routine for Rhapsody. I have also updated both Sansa Clips’ firmware to v02.01.32a, tried transferring using two different USB cords, and several USB ports on my computer. About the only thing I haven’t done is reformat the thing. After having to tranfer 600+ tracks 3 times in two months I’m rather hesitant in doing that.

Would anyone, please, help me fix this?

It might sound stupid but… Are the Headphones in all the way? You have to use some fourse.

Definitely not a headphones problem. I’ve tried two different sets of headphones on each Clip, and since the Clips are stationary during playback (the longer tracks are meditation music) it’s not a case of the plugs causing static while rolling around in the jacks.

I can’t really give a better description of what I experience with my son’s Clip, but with mine it’s clearly not random thing. I’ll hear a faint pop in the left ear, a faint pop in the right ear, then a louder pop in the “center”. Rinse, lather, repeat.

Ah, let’s add some luster to your clusters.

The file allocation table of your Clip has wee 4KB clusters.  Since you have a 4GB unit, this FAT is pretty big.

Decoding Rhapsody tracks requires some number crunching, since the files are secure wma at 160kb/s.  The Clip is tasked with finding the next block of data, but it has to look at that huge FAT.

The solution is simple!

Turn on your trusty Clip.  Go to Settings > Format > Yes.  This will format the device with 32KB clusters , optimized for the Sansa.

Please note that this will delete all existing music from your Sansa, and you’ll need to reload.

On the other side of the coin, you’ll hear clean sounding music from now on!!

If you format from Windows, it has the nasty habit of formatting with those teeny 4KB clusters- and the resulting stutter will drive you crazy.  If you format from Windows, ALWAYS follow up with a format on the device via Settings.

Bob  :smileyvery-happy:

Woot!

That did the trick! Thanks!!!

So, does this mean formatting via the device is preferred over formatting by either Windows or Rhapsody?

Definitally!

Formatting from Windows is beneficial sometimes, but it should always be followed by formatting from the Clip menu.