Solved ? - Playlists not working after (manual) firmware upgrade - MTP mode

Aaaaarrgggghhh!!! So new player, first thing I did was upgrade firmware, but I’m thinking this is what messed me up, after several hours of syncing, formating etc etc in vain attempts to get Windows Media Player to sync its playlists, I finally have a playlist YEEESS !

So - if you’re reading this, check in settings what your USB mode is set to, mine was on MSC and from what I’ve now found on the web this does not support playlists from WMP.

Once you switch to MTP the player will appear on the left in WMP as “Sansa Clip Zip 8GB” or something similar, right click “Setup sync” strangely it gives no options at this point, but click Finish and then right click “Setup sync” and now the dialog is completely different (noooooo thats insane !!) and lets you select which playlists to sync.

Posting a comment to the firmware thread as well, looks like a stupid mistake by Sandisk to set the USB mode wrongly. I’m sure some people will want to use MSC, but I’m equally sure that MTP is what most people need.

See also this thread for discussion of MTP or MSC mode. 

Isn’t there an “auto detect”{ - I think that’s what I used to sync - but I have not tried play-lists yet - so far I just synced songs and use shuffle play

There is an auto-=detect which should also work - but the firmware defaulted to MSC.