SMC Download Error

I’ll try to shorten this down as simple as possible.

*Owned e200 broke it so I had to get a Fuze.

*Had SMC on the e200 but since it didn’t read the Fuze I deleted it along with the ArcSoft Software

*I TRY to download SMC from the Official Sansa Website

*It will download the Unboxing application but once it gets to the “Install Wizard Setup”

I get the following message

“Setup failed to run installation:  The remote procedure failed”

Anyone know what I can do…and I’ve already reset my CPU and I’ve downloaded the SMC thing about 6 times with the same results.

I really like my Fuze (even though it’s scratched TOOO EASILY) but I really want my video capabilities.

that means the RPC service is not running on your computer

  1. rightclick on ‘my computer’.
  2. select manage
  3. click on ‘services’ under ‘services and applications’
  4. look for remote procedure call (RPC) on the main window
  5. rightclick on it then select “start”
    after these steps, try to run the installer again

Thank you very much,

But it did not work.

 You had the most simple explanation I’ve read in about 3 days though…and I’ve been searching all over for a solution

So what do you think it could be then?  I turned on the RPC and the RPC Locater…when they didn’t work I restarted them both…and set them to automatic so they could work on their own. 

Is their anything else that may be messing up my Set Up process?

This is really frustrating because your solution sounded completely perfect.  But yet and still it didn’t work.

There are two open paths to the Sansa Media Converter.  Try this one which points directly to the SMC version 4.236.

The other one has been repaired, the one available on “the red side” of the SanDisk website (by clicking the SanDisk logo in the upper left corner of this page).  The link is available via support / downloads.  It has a screen requesting registration (just for update notes, possibly), but if you’re here, you can find information readily.  Skip registration if you wish.

The link I tabbed above is a unique one, as it goes directly to download. (Yes, it’s an official link, not some site in Kazakhstan.)

If you’re running Vista (Windows ME II), you have my deepest sympathies.  Be sure to run as administrator if it is unhappy with you.

Bob  :smileyvery-happy:

THANK YOU!!!

 

I finally got it to work!  I think that turning on the RPC’s may have helped…b/ I think my initial mistake was deleting the ArcSoft software.  I re-downloaded the old version of SMC and then ran my updated SMC and it worked (b/ it took like 10 minutes for the setup to come up)  I got lucky because I was just about to close the Setup menu…and it started working!   I finally have my money’s worth on my Sansa.  Now all that’s left is to buy a crystal case.

Glad to hear it’s working!

You’ve touched upon an interesting quirk with the Sansa Media Converter.  I have seen recommendations (based upon traditional installations) to first uninstall the old converter, then install the latest one anew.

For obvious purposes here, I try intentionally messing up applications, to see what happens when the resulting “mess” is tried.  This is analogous to the relationship between the scientist and the engineer.  I find great sport in seing what happens when things are pushed outside the comfortable envelope of what’s assumed will happen.

To make a long dissertation brief, I installed the new version of the SMC with the old version still installed, just to see what could go wrong.  The installation recognizes the old version, and makes the appropriate patches.  Perhaps, this could be part of why I’ve never had the SMC skip a beat, no matter what I throw at it.

Then again, it may be the solar wind, or neutron flux.

Bob  :smileyvery-happy: