SMC Connection issue

Whenever i use SMC, it always claims that my device (e240 or something like that) is not connected, even though i can access it fine from anywhere else on the computer. how do i fix this?

I have the feeling that the software preloaded with the fuze is hardcoded with an updater link which has been changed or no longer available. I’ve tried links provided by many posters on the board but the links does not resolved.

I have the same issue…and its yours and my fault that we don’t know how to use and configure the device and read and follow Satans’…err Sansa’s documentation.

It’s you and my fault that Sansa’s site links changes often and their documentations are out-of-date.

It’s you and my fault that Sansa’s is clueless about what’s going on with their stupid product.

It’s you and my fault that Sansa’s doesn’t care about customers satisfaction.

It’s you and my fault that Sansa’s products is just POS. 

I hope you realise that your comment is no help at all… it’s a diagnosis, not a solution. i want a solution.

Have you tried MSC mode on your player?

it was already in MSC mode, so i tried it in MTP mode and it works!!! :smileyvery-happy:

That would have been my 2nd suggestion. :stuck_out_tongue: