Should the Screen take this long

Ok I bought a Fuze for my wife’s birthday this week, and I must admit its a very nice piece of kit, but should the screen take 5 secs approx to update every time a button or wheel is touched?  This seems a very long time and can add minutes to simple operations like deleating all the pre-loaded songs. You can still operate the Fuze even with the screen blank, as long as you know which sequence of buttons to push.  Secondly having put some music on the Fuze, all plays well execpt 1 album (Lady Gaga) it just seems to jump through the tracks without actually playing any?

The five-second pause is not standard behavior, so a firmware update might fix it. 

As with any new gizmo, it never hurts to update to the latest firmware. You can find the instructions and downloads


I suggest following the manual instructions–all you have to do is unzip a file and put it on the Fuze–rather than installing the Sansa Updater.

You don’t need the updater loading every time you start up, and you don’t need the computer contacting SanDisk every time you plug in the unit. The current firmware is very evolved, and if you look at this forum every month or so (or two months), you can see if there’s a new one–if you care that much.  

If the firmware update doesn’t fix the problem, take it back and get it replaced. It’s defective.

What’s happening with your Lady Gaga album is a little like a bad romance–the partners just don’t understand each other. The album was probably converted to a format the Fuze can’t read–did it come from iTunes? So the Fuze shows the files but then realizes it can’t play them, and skips to the next. And the next.

The Fuze plays mp3. .wma, .aa (audiobook) and .ogg files. If Lady Gaga is .m4a, .m4p, .aac or some other filetype, the Fuze won’t play it. (Meanwhile, iPods won’t play .wma, Windows Media Audio. Why can’t we all just get along?) 

You may have to set your Windows not to “Hide extensions of known filetypes” to see what’s going on. (Open My Computer/Tools/Folder Options/View in Windows XP, might be different in Vista and Win7.) 

If you have iTunes on your computer, under Advanced it has a Create mp3 files function to convert those files to .mp3. Just highlight them and run it.

Or, better yet, convert the album to mp3 directly if you still have it.

With iTunes, under Edit/Preferences/General/Import Settings (they really don’t want you to find this), you can  set iTunes to make .mp3 files (Mp3 encoder) from every album it rips instead of its default setting, .m4a or .aac (I forget, but they are both Apple’s own formats). 

If you got the Lady Gaga from someone else, and don’t use iTunes, you can convert the files to mp3 with the free Media Coder. 

Windows Media Player rips to .wma by default, which the Fuze can handle. But for universal play, and fewer eccentricities, you can also change WMP’s default to rip to .mp3 as well. 

I know this seems complicated, but once you have gotten your computer to give you mp3 files, the Fuze behaves pretty well. 

Thanks for your reply, will try a manual firmware update, I did the one using the installer this morning, but you never know.  Lady Gaga was ripped using windows media player, like the other albums all of which work fine.  Will trying a re-install of the Album and see if that works.

Go into Windows Media Player settings (Rip) and make it mp3 at 192 kbps or above (for good sound quality). The default on WMP is to make a “protected” .wma file–protected from YOU being able to play it wherever you want. You want to change that setting anyway, no matter what player you have.

If the latest firmware doesn’t help, definitely take the Fuze back or call 1-866-SANDISK (in the US, you may be British–find the customer service number) for replacement by mail.