Settings not retained?

I noticed that everytime I turn on my Express I have to select the language to start and then settings like Shuffle and Repeat are back at the defaults. Is this normal? If not anyone know how to fix it? I just loaded the newest firmware and it still does it.

Thanks!

No, I don’t have that problem.  Mine retains the settings.  That would suck if you had to do that all the time.  But so far I haven’t had that problem, and I’ve had mine for bout about a month.

I have no problems with it retaining my settings.

If I’am in the middle of a track when I turn it off, it will turn on the same place. [very useful for an audio book.]

Hi mt_100!
You aren’t alone, because I have the same problem .-. But it’s not everytime when the player starts. I noticed that it crashed after charging it or when i have transfered some mp3s to my device. Dont’t know what do do and dont’t know the reason!! Thats definitely a firmware bug. Why SanDisc have made any beta tests? They are so many problems with that thing…

Grr… Greetings :wink:
MrPotter

Same symptoms here - have had this player for just over a week and it’s hit and miss.  Sometimes is will go a day or two without losing the settings, then other times it resets almost everytime you power cycle the device.  I use this mainly for listening to FM radio through a motorcycle intercom system back and forth to work, so it’s a royal PITA having to rescan for FM channels each time I turn on the player.

Has anyone reported this to Sandisk?  Have they responded to anyone on this thread?  I have had trouble with their firmware and/or drivers in the past on memory card readers.  I work for a software company and if we let product into the wild that had this many problems, we would be bankrupt by now.  Hopefully Sandisk tech support is reading this forum and will address this quickly with a firmware update - otherwise this Express will be going back to the point of purchase for a refund and I will be done with this brand altogether…

Hi there

I’m another one who gets the problem with settings not retained and startup at the language screen.

I took the unit back, got a new one, updated the firmware and presto - same problem. Am waiting till sandisk provide firmware that works. In the meantime got  a samsung yp-u3 which works fine, even if the sound quality isn’t as good.

I have the same problem too. I tried to create an on the go playlist and the express reset itself everytime I powered off after that. I cleared the go-list and it seems to have helped but it still loses its setting about 1 in 3 times. Since I use it almost exclusively for listening to audio books it is totally unacceptable to have to find the right track and then skip through to the right place everytime. Especially since the fast forward does not get faster the further you go. Fast forwarding 50 minutes takes ages.

I have the same problem too. I tried to create an on the go playlist and the express reset itself everytime I powered off after that. I cleared the go-list and it seems to have helped but it still loses its setting about 1 in 3 times. Since I use it almost exclusively for listening to audio books it is totally unacceptable to have to find the right track and then skip through to the right place everytime. Especially since the fast forward does not get faster the further you go. Fast forwarding 50 minutes takes ages.

I’m also having the same issues, the unit will reset at random.  Doesn’t seem to be any rhyme or reason to why it does it.

Same here.  Random resets.  Today it happened twice in a row.  Yesterday once in the morning once in the evening.  I have to go into every settings’ subfolder and reset everything, including my FM presets.   Pain in the butt.  Does it do any good to ask for some support here, Sandisk??

Thanks in advance,
I really like this player aside from the bugs.

I haven’t seen the settings problem, but I didn’t know I could turn it off and that it would come back where it left off in my audiobook when I turned it on. I tried pausing and locking, but whenever I turned it on it was back at the beginning of the track.
Thanks to Starhunter5’s info I just turn it off and when I turn it on it’s back where I left off; I’m a lot happier with it now.

I have noticed a considerable amount of variation in the unit’s behavior with regards to resetting.  After removing one audio book and loading another, in the process recharging the unit, it didn’t reset itself for several days.  I’m just curious if anyone else in the community has noticed any sort of trend with it, perhaps there’s some trick that will keep the unit stable?

Hi there,

I bought my Express yesterday at bestbuy and upgraded the firmware.  Now I have the same problem.  I also cannot fast forward to the next track.  Any ideas are welcome!

Thanls

I have very similar symptoms.

  1. Randomly looses all settings
  2. Randomly forgets which track it was playing
  3. When it does remember which track, it almost always starts from the beginning of the track.

This makes listening to audiobooks quite a pain!

I have also seen this same issue reported elsewhere.

Err… Anybody from Sandisk care to comment ?

I have same weird behaviour…

They need to make an firmware up to date that will fix this !!!

OK, let’s be real here.

SanDisk didn’t set this forum up to do one **bleep** thing to help users. They set it up so users could FEEL like they are being helped.

SanDisk has our money, that’s all they want.