Serious problems with Audiobooks

My Clip is wonderful at playing music but I’m having no end of issues getting it to play (non-Audible) audiobook files. Sometimes (as with my audio copy of The Economist) the files are displayed hopelessly out of order: 80, 79, 76, 75, 73, 69 etc etc down to 01. Re-naming the files does nothing.

Some book which are split into Discs play tracks in sequence but the Discs themselves are displayed out of sequence, eg. Disc 16, 15, 14, 01, 02 etc etc.

Any ideas? I love the little thing but listening to Audiobooks is the key non-fitness function I have for the it, and if it can’t manage to play the tracks or albums in order I’ll be forced to return it.

Cheers,

 - WireFire 

since renaming the file didn’t reorder it, please check your track# tag for your audiobooks.  Most of your out of order examples seem like they are in descending order than out of order, please verify if it is descending or out of order.   If they are descending they’re might be something wrong with your clip in where it is treating the audiobook section the same as podcast (podcast displays as descending order, in order to list the most recent at top).

Also if you do not have the latest firmware I recommend updating to it and performing a clean MSC format before u transfer anything.

The clip ignores disc number tags so you have to rely on the track number tags alone.

Before I updated my firmware to the latest version, my audiobook chapters would download beginning with chapter two and finishing up with chapter one at the end.

@thoma wrote:

since renaming the file didn’t reorder it, please check your track# tag for your audiobooks.  Most of your out of order examples seem like they are in descending order than out of order, please verify if it is descending or out of order.   If they are descending they’re might be something wrong with your clip in where it is treating the audiobook section the same as podcast (podcast displays as descending order, in order to list the most recent at top).

 

Also if you do not have the latest firmware I recommend updating to it and performing a clean MSC format before u transfer anything.

It’s actually both, the track that plays first on an 80-file album is track 80, but after counting down three or four tracks (79, 78, 77, 76, for example) it will then jump to 69, 68, 67, then perhaps back up to 75, 74, 74, then over to 59, 58, 57 etc etc.

I updated the firmware within a day or so getting the player. 

 - WireFire 

ok. so how about your track # tags? what do those show for each file. you can view that info with any media player (winamp, windows media player, media monkey, etc). if they are incorrect go ahead and change them and see if they display wrong again. if they display wrong, I suggest performing an MSC format and trying again. if you search threads I’ve posted for “msc format” you should get some results on how to do it. hopefully the format fixes it, if not you may have a defective clip.