SecureAccess Vault issue

Hi I have Sandisk Extreme USB 3.0 64GB flash drive, which I was using for  keeping some personal files and folers.

For that purpose I installed Secure Access software set the pass and imported all files in the vault.

Recently I plugged the Flash drive in the PC which seems to have Flash drive Virus, which has wiped all the data from my flash drive, including Secureaccess EXE file.

However the virus left only VAULT folder and hide it:

the Vault folder looks like that:

I se that Flash drive contains data, as out of 64 nly 25GB is free.

Is there any way to restore EXE file and access VAULT? or restore data directly from VAULT?



You can certainly download a new copy of SecureAccess to the flash drive and install it.  Whether it will allow you to access the old vault I don’t know.  It’s possible the old files are lost and you will be starting over.

Hopefully these links will help you.

Thanks for the reply. I will try to follow the instructions

It works, I downlaoded the Secureaccess exe file, placed in the same directory and after opening it, the applicaiton asks that vault exists and I just need to repair INDEX file. 

The repair process starts but at the end software hangs and stops responding. 

Is it known issue?

Good to hear you’ve made some progress.

I don’t know about the hanging situation or how to fix it.  If you can somehow get out of the hang, pressing Esc or some key combination to end it, try running a CHKDSK command on the drive and see if it reports any problems.

I have a very lighly used Extreme Pro 3.1.  Everything seemed to be working fine with it – no lockups or freezes, no issues when adding files to the vault.  Then one day I plugged it into one of two computers I always use it with and … nothing.

The Secure Access Vault just won’t open.

When the drive is plugged in, I can find it in the device manager; it is properly identified as “SanDisk Extreme Pro USB Device.”  It is described as “working properly.”  However, it doesn’t appear as a drive in Windows Explorer, so the screenshots posted by GBregvadze are a step beyond where I can get.

Any suggestions on how to bridge the gap so I can try this solution?

Is this a warranty issue worth contacting SanDisk about?

Thanks in advance!

Windows is notorious for assigning the same drive letter to different devices.     In Device Manager assign the drive a drive letter.  Once accessible in Windows run a CHKDSK command on it.

Hi Ed,

I reassigned the USB to be the X drive.  That allowed it to appear in Windows Explorer.  Here is what happened when I tried various things:

TRIED: opening the drive the regular way (double-clicking)

RESULT: a lot of spinning blue circle, then an error message: "Please insert a disk into USB Drive (X:)

TRIED: opening the separate SanDiskSecureAccessV3_win.exe program that I downloaded

RESULT: error message: “This application only runs on a SanDisk flash drive”

TRIED: running “CHKDSK X:” in the command prompt

RESULT: “Cannot open volume for direct access.”

Any suggestions on what the next step is to try?

Thank you for your help!

That CHKDSK command results are strange.

Ok, let’s try these steps:  :smiley:

  1. Safely Remove the flash drive.

  2. Reboot the machine.

  3. Insert the flash drive.

  4. Does it show in File Manager?

  5. If not go to Disk Manager and assign a drive letter.

6.When it shows up in File Manager copy the “SanDiskSecureAccessV3_win.exe program that I downloaded” file to the flash drive and execute it.  You can not execute the V3 download file on the hard drive, it has to be run on the flash drive.

  1. Once the V3 install is done try SecureAccess.