SD micro card acting up (when using SMC)

ok, so i have a Crucial Miro SD card (1 GB) that i but in my Sansa Fuze (2GB) and i aready Formated the SD card, and it shows up in My Computer. it shows there that i have my 1 gig of memory there but when i turn on SMC it shows that i have 1999.7 mb of total space and only 6.1mb of space left on it. im so confused at this point, also when i tried to put a movie on the player, it failed to put it on there. i have the usb settings on auto detect and it seems to work fine.

so any suggestions? ^^

ok so i formatted the player (using the players format function) and it seems to have fixed it, but i dont know what happened to it in the first place

Pass, just one of those things.  Glad it’s working for you now though!

now today when i plugged it in, the same thing happens in SMC, and i really don’t want to format the drive again

can i have some help please?

The 6.1 MB may mean there’s a file the Sansa can’t read: bad, corrupt, inexplicably disliked.

Try running Error Correction on the affected drive. May work, may not. 

http://forums.sandisk.com/sansa/board/message?board.id=announcements&message.id=147&jump=true#M147

If not, you’ll probably have to Format again.

But then, instead of SMC, try running your movie through video4fuze:

http://code.google.com/p/video4fuze/

You might also have better luck putting your movie on the internal memory and the music on the card. Some cards just don’t work well with video.