SD card stuck in slot

so my (refurbished) fuse+ came in the mail today.  One of the first things I tried doing was putting my 32gb micro SD card in the slot.  To my surprise, it would go in, but it wouldn’t come out. I put it I the right way (unless I was supposed to put it in upside down).

anyone have any tips on how to get it out?  I paid almost twice as much for the SD card as I did for the fuse, so if I have to rip it apart I will (but only as a last resort).

Are you pushing the card in with your nail and letting it pop out? If you can’t push it in enough with your finger to get it to unlock, you should use a paper clip or some other available thin item to push it in. Do this on a desk, as the card can sometimes be sprung out quite a distance if you don’t catch it.

It went in fine.  When I tried to push it in again is when the problem started.  I tried using a paper clip to push it in, but it wont budge.  When i pushed it in the first time it almost felt as if there wasnt a spring in the slot.  Maybe this is why the player was refurbished in the first place.

 I guess you could send it back to the place you bought it if you purchased it recently. Let’s see if someone here has any ideas. I guess the card is stuck in place so you can’t grab it with a tweezer.

My SD card is stuck crooked in nook color and will not come out. Is there anyway I can removed or will I have to send it for repairs?

Maybe you should find a Nook user board.

If the spring is broken, I think it needs to have a technician to do it for you. Forcing the issue would only pose problems. Just saying.