SATA 5000 drive locked ?

I have an old 16g SATA 5000 SSD  not a flash drive. All of  a suden it acts as if it is write protected.

The Sandisk tool box reports its in a frozen security state any idea what is hapening. Oh I tried to do the secure

erase and it says this function is not suported. I even tried to install Ubuntu on it but Ubuntu can’t write to

the disk either. I don’t realy need it but hate to toss it out if it’s an easy fix.


in that case the drive seem to be defective and need to be replaced. As i understand this drive was built inside a host device so in that case i would try to contact the manufacturer of the device to see what else can be done with the drive or how you can replace it if still in warranty. 

got it solved….!!!

If it is write protected Here is the solution:

  1. Open a Command prompt by clicking Start, typing command , and clicking Command Prompt.

  2. Type diskpart and press Enter.

  3. Type list volume and press Enter.

  1. Type select volume # , where # is the number of the drive that’s giving you the “write-protected” error. In my case, I ended up typing select volume 3.

  2. Type attributes disk clear readonly and press Enter.

  3. Type exit and press Enter.


If it is freeze security lock then you need to get it replaced.