SATA 1 speeds on SATA 2 motherboard?

Hey guys, I seem to be getting very slow speeds on my freshly installed 240gb drive.

I got the same result from CrystalDiskMark and ATTO benchmark.

Windows was a fresh install onto the drive, AHCI and ACPI 2.0 are enabled in the bios, windows reports TRIM commands are enabled. 

They seem to be consistent with SATA 1 speeds, though my board (Asus M4N98TD EVO) is SATA 2 capable. Apparently nforce chipsets do not play nice with sandforce ssd controllers. I upgraded my nforce drivers to the latest version, did not make any difference. 

There are numerous reports of this problem on various other forums. OCZ seems to have solved the problem with a firmware update.  I was going to update the Sandisk firmware, but noticed there was no mention of this problem in the update notes, and the ‘update at your own risk’ scared me off.  Am I going to void my warranty by updating?  Is there anything else I can do?



update will not void warranty. i would suggest trying the firmwre update. it does nto touch user data but you will need to back up just in case. 

Ok, firmware updated. Still connecting at sata 1 according to the sata controller info in the device manager, and the benchmark programs. My old hdd is connecting at sata 2 speed.  Any more ideas, or am I going to have to buy a new motherboard to use my ssd properly? :s

Unfortunately with the sata chipset your board has it probably is not going to connect in SATA II. You might want to get a new board. 

We recently isolated the same problem with a SanDisk Extreme 120GB SSD

cabled to a Silicon Image 3132 SATALink controller here:

The current transfer mode was set to Ultra DMA Mode 6 for that controller,

which is equivalent to ATA-133, or 133 MB/second.

This problem was bypassed by moving that SSD to an Intel ICH7R/DH

SATA RAID controller:

And now, the SanDisk Extreme 120GB is running at SATA-II speed

with an interface of 300 MB/second (max bandwidth):  this is correct,

because our motherboard does NOT have any 6G SATA-III ports.


You talk as if “getting a new board” is easy.  Those having the nforce issue have a computer that is 2-4 years old.  To “upgrade” the board requires a new board, cpu, and RAM.  Thats 500 bucks right there.  Those with Macbooks would have to buy a new laptop.  I “upgraded” from a OCZ Vertex 1 from 2 years ago that was 230/270.  This new drive runs at 130/133, so I LOST 50% speed in my upgrade.  OCZ has a fix for the same issue that forces the drive speed to be SATA II.  You just have to apply the fix from a boot disk.  You need to either write a firmware update to address the issue or people are better off buying from OCZ that didnt just pass the buck.

I guess the true test will be if they bring out a fix for it in a timely manner (if they do at all), since OCZ have demonstrated that this issue is fixable.

Looks like the final word is ‘buy a new motherboard’.

Would’ve been nice if sandisk had mentioned that their drives do not function plroperly with nforce chipsets before I bought it.

Ah well, at least I know now to stick with tried and true harware manufacturers.

Don’t worry, I’ll be sure to let every nforce owner know not to buy your drives on as many review sites and hardware forums as I can. Thanks for your time.