Sanza Fuze Says Charging But Doesn't

OK, I have a Sanza Fuze that seems to be malfunctioning…

I’ve had it for a few years now so it could possibly be that the battery has completely ran out of juice. Regardless, I’ve tried the hold & <<<< MSC mode method. I’ve tried the power button for 30 seconds method. I’ve used every USB port possible as well.

The problem is that the device connects & says “Charging” but remains at 0% no matter what. I’ve had it plugged up for about 2 hours & it remains at 0%. Should I just replace the battery or is there another method that can fix this problem?

It’s possible the battery and/or charging circuitry has worn out or failed. Unfortunately, the battery is not designed to be replaced in this model.

But it could be a matter of a bad cable too. Even though the unit says it is charging, it is not. These are simple (and inexpensive) enough to try. You might also try an AC-USB charger.

How about a firmware upgrade? But if the charging indicator is the only one affected but it is indeed charging, I wouldn’t worry too much about it.