SansaFuze "Loading"

My new Sansa Fuze is frozen with the word “Loading” on it.  I tried to update the firmware and that’s what happened.  I cannot get to the menu or the settings.  I tried holding down the “on” button for about 40 seconds and that did not help either.

If it’s new with a warranty, send it back. You shouldn’t have to deal with this kind of problem with a new unit.

If it’s a refurb or used, there’s no warranty.  Maybe the firmware you were trying to install was corrupt or incomplete. So try again.

Hold up the power button until it goes dark. It will, sooner or later. If it doesn’t, leave it on until the battery dies.

Download the firmware from the All Regions link in this post:

If you don’t know what version your hardware is–1 or 2–then download both firmwares. They are .zip files. Unzip them–the Desktop is a good place-- and in the folder you’ll see a binary (.bin) file that starts with fuze, like FuzeA.bin

Time to play with the unit. Slide the power button down into the Hold posiiton. It clicks, and there’s an orange dot in the slot.  Connect the USB end of the cord to the computer. Open Windows Explorer (Computer or My Computer).

Hold down the << side of the wheel. Connect the connector to the Fuze and hold the << until two drives pop up in Windows Explorer: Sansa Fuze:  and Removable Disk.

Drag the .bin file onto the Sansa Fuze drive. Disconnect and the firmware should install itself. If it doesn’t, repeat procedure with  the other firmware version.

Hi udhdave, how did this worked out for you? 

Thanks for the help.  I can now get to the menu.  Next question: how long should the battery remain charged?

@udhdave wrote:

Next question: how long should the battery remain charged?

Depends on your usage patterns (how often the backlight is turned on, how bright it’s set to, fiddling with the buttons, etc.) and the type of files you’re playing. Could be anywhere from 4 -5 hours all the way up to 15 hours.