Sansa won't erase old music?

I have run into a problem with my sansa clip player where I can’t get the old music to erase.  If I had to guess, I believe it may have to do with the fact that I originally loaded the songs on my clip on a PC computer, but I have recently gotten a Mac.  When I plug in the clip to my Mac computer, the old music doesn’t show up in the music file and it is blank, so I am unable to get the old music off the player.  I tried plugging the clip back into my old PC, and it still doesn’t show up.  When I try to do the “reset all” function under “settings”, it does nothing when I click “yes.”  Any idea what I can do to get the old music off of my clip player?  

The “Reset All” only ‘resets’ the factory defaults from your personalized settings (Brightness, Backlight, Auto Power off, etc.). So yes, it’s doing something when you click YES, just not what you are expecting.

To clear "all’ your music off and start afresh, _ format _ the player.

The issue you’re having with not being able to “see” your music in order to delete it while connected to your computer is most likely the Auto/MTP/MSC USB Setting. Files loaded in MTP cannot be seen while connected in MSC mode, and vice-versa. The Auto Detect mode (or Auto Defect as it’s referred to around here) can and will connect in either mode depending on what conditions it encounters when plugged in. Big problem.

The default setting is the Auto one. Probably what happened is you (not knowing about this) when you first got the player, plugged it into your computer and the Auto setting connected it in MTP mode. You loaded your tunes and everything was hunky-dory.

Now that you are using a Mac, MTP mode won’t work (as it’s a Windows Media Player thang), so your player is sensing WMP is not installed on your Mac and is connecting in MSC mode instead. Which leads us back to the 1st problem, it can’t see the files that were loaded in MTP mode.

So as I said, best to format the player which will erase all user-added content, manually change your player’s USB Setting to MSC and then move forward.


Thank you very much for the response-- however, I just changed the USB mode to MSC under settings and I still cannot see my old songs on the clip.  I’m sorry to ask again, but any idea as to why?

Because as I previously said, files cannot be seen by your computer unless the player is set to the USB mode in which the files were originally transferred in. I’m guessing by your description they were orginally transferred with the player set to the Auto mode, which defaults to MTP.

Unfornately MTP won’t work on a Mac, so I believe you will need to set your player to MTP mode and connect to a Windows machine. You can then re-set (unplugging first) the player to MSC mode and transfer the files back to the player. Now when you plug into your MAC you should be able to see and manage them.