Sansa Startup Freeze Problem Solved - needs two m2x0 players

I’ve got a brand-new solution to the Sansa m2x0 startup freezing problem.

Notes:


* To unfreeze, you’ll need another similar BUT working player. (I’ve tested only on an identical model, but suppose similar models will work as well.)
* You’ll need opening the cases for both players. If you can’t afford breaking the healthy one, think twice.
* Opening the player cases was not easy. It took about ten minutes to understand how to open them without breaking them. I’ve opened the second one in about three minutes. I was careful and managed not to harm them at all. I used a screwdriver and a kitchen knife to do the job.

First about the problem I’ve got:


I’ve tried renaming an audible .m4b file to .aa to see whether it will work or not (I know it was quite a silly test, but I didn’t expect the device to hang that badly.) After disconnecting, the initializing window was frozen (the second screen “Sansa m230 512MB”.)

When connecting to the USB port, the player didn’t make to the second screen and stayed frozen.

I’ve contacted with the Sandisk support, which was quite helpful and friendly but couldn’t solve my problem. They’ve suggested a replacement but we didn’t need to get there…

From the multiple postings in several forums, I’ve found that most frequent reason for this symptom is synchronization related, i.e., problems with handling the new files and updating the internal library.

Solution:


Here’s what I’ve done to unfreeze my Sansa m230:

  1. I’ve opened the cases of both our Sansa m230s.
  2. Connected the healthy one (which was in MTP mode, MSC should work as well) to the computer via USB.
  3. After it was connected, I’ve hot-swapped the “Samsung k9k4g08u0m-pcb0” memory chip with the one, which was causing the problem. This chip is kind of hard to detach. Examine it carefully before applying to much force on it.
  4. Finally, I’ve formatted it through WMP10.

Hope that helps some of you.

Please drop a line to tell us about your results.