Sansa Media Connect!!!!

I now have sansa media connect but, after downloaded off sandisk site. I tried to send video error box pops up?  I tried over and over again help what do I need to do to get video working?

What firmware version is on your Connect?

Go to Settings>Info>Software Versions

Current version is ZAP:

Also, what version Sansa Media Converter?

Go to upper left corner, help, about

I have the right versions #. But, when I’m in the file media player. i get ready to download it has a box with a error message.

hmm…there is a problem that if you transferred using SMC to the player, that you have to full power OFF and ON the Connect to do it again. Maybe something like that is happening. Try full OFF and ON to check.

If it persists, what is the error message stating? And what type file are you tranfering?

I’m transfering a mpg video though sansa media converter. What size of a video is called for? To avoid error

The SMC has worked for most of the files I tried.

I’ve converted small .wmv, .jpg, .mov and feature film .avi files

I’ve had a couple small .wmv files that give error ‘Invalid Format’ (just assumed they weren’t proper)

What is the error message and at what point do you get it?

I am testing now with .jpg file

  1. Plug Connect to USB

  2. At auto-start popup, select use SMC

  3. SMC starts

  4. Select Add Media, select file, click open

  5. Select Convert

  6. File converts and then transfers

 Now, were do you get your video’s from? i did all that with plugging the usb port in, then selected smc though the pop-up. then add media, then convert and the message that pops us is:  

Sansa Media Converter.exe has encountered a problem and needs to close. We are sorry for the inconvenience

If you were in the middle of something, the infomation you were working on might be lost.

Ouch. That’s an application error message. Do you get this with any other applications?

I’ve been getting that error a lot with IE on my machine, meaning I problably need to clean house and rebuild my system.

There is something loaded on your PC conflicting with SMC or just screwing up your memory management.

First try uninstall and re-install SMC.

I uninstalled twice and re-installed. Then, I restarted my computer plus, my player!

I’ve been messing with trying to load video’s like hours and hours on end. I’m ready to give up. Can anyone help and tell me what I need to do!  :womansad:

1st: Were do I get video’s to download

2nd: What size does the video have to be?

Some people in the View forum suggest trying

convert to mp4 then drag and drop into video folder


The video specs that work the best on the Sansa Connect are as follows:

  15 fps, under 700kps, 320x240 size.

although i think SMC converts to 24fps

Message Edited by Greig on 12-28-2007 02:01 PM

Is the a video time limit like with the Sansa e200 series? Can i put videos longer then 15 minutes on the connect?

No time limit.
I’ve had several full length movies on the connect.

But you need the newer Sansa Media Converter program that they updated at the end of November.

I cant just convert the files to mp4 like i’ve done with my ten minute and under clips?

You can use another converter, but SanDisk will not provide support for you if you have problems getting them to play.

But you shouldn’t have any problems if you format to mp4 with the correct display properties.

See my earlier post.

Message Edited by Greig on 01-02-2008 10:25 AM

My 9 year old is anxious and I’m losing patience trying to get videos downloaded.  Thanks for the great leads though with your input on what seems to be the same problem.

Sansa Media Converter fails with “Sansa media converter.exe has encountered a problem”.  The generic application error.

I’m running Windows XP Home Edition with SP2 and just checked and downloaded the latest fixes, nothing looked related.

I downloaded the version from the Sansa website, it showed on the link on the site one version (4.220).

Download version: 4.220  86.3 MB  11/15/2007  WinVista,WinXPSP2  English  

I find it strange though that when I run the software and get to “About” it shows a version 1.0 B004.220CDG 

I have searched the web trying to find the right version (some comments about you need the next version to get longer video capabilities).  

On the Sansa SanDisk e250 v2 I look at settings and it shows Version V03.01.11A.  I assume this is the firmware level.

Based on your thoughts I loaded AnyVideoConverter (free version 2.5.7). 

I changed the profile in the upper right to use mp4 and then set the following technical output per your post

15 fps

700 kps


The codec has two choices xvid and mpeg4. You didn’t list a codec. Perhaps could this be it that my system needs something else?

I then drag/drop into the drive under the video folder and it states with an error message that these files can be copied for transport but the device doesn’t support them.

Any other thoughts?  I’d love to have SMC work, but happy to keep trying the freeware as it looks to be easy to use.

Thanks Paul.


The current version is 4.220 (aka 1.0 B004.220CDG).

What Sansa product are you trying to transfer the videos to? Sansa Connect or Sansa E250?

I physically want to get it onto the hardware, the Sansa SanDisk e250 v2 player.  I can’t drag and drop the files or they say they don’t work so I assume I need to “convert” them through the  Sansa Media Converter.   

Am I not understanding something right?  I have a Samsung that I use a Samsung software converter for and it works just fine.

Ah sorry I see nwo that Sansa Media Connect is another mp3 player.  Not is the Sansa e250 v2 that I am working with.  It seems like it is the software converter that is the issue. I am hoping it is simply that the codec or the resolutions or something related to the videos is the issue.  Any ideas?


The E250 is in a different forum and the video format supported is different than what is posted in this forum which is for the Sansa Connect.