Sansa m250 subscription tracks

When i transfer tracks from my rhapsody subscription to my player, there is no problem with syncing.  It’s when i start to play the files that the problem occurs.  around 10-15 tracks will play without any trouble, then all of a sudden they stop playing, and i get a message on the player “Synchronize to continue your music subscription”.  This happened yesterday, then after i synched it, the tracks were playable again.  10 tracks later the same thing happened.

What are the file types of the tracks you are syncing to your player?

   The same thing happened to me.  I terminated my membership in URGE/Rhapsody because

the service suddenly turned EXTREMELY bad…   But I am still having the same problem with

my Sansa M250.   All of the music on my Windows Media Player has come from my own

CD’s, records, and cassettes, but I keep getting that message to sync so my music

subscription won’t expire…  What gives???



When you ended your subscription, did you deauthorize your player?

Can you tell us how to ‘deauthorize’ our players?

Thanks :dizzy_face:


Do yourself a favor kick all the subcription services and Microsoft in the butt. Get Winamp and CDex use CDex to rip your cd’s to mp3 and winamp to organize your files and add to your Sansa. Don’t use wma files or any kind of special file. Plain mp3’s are not protected in anyway. I had napster and when you want to listen to your files you are no where near your computer so you can update the subcription. Do yourself a favor exchange CD’s with friends, go to Amazon and find a used CD from the artist you want. CDex rips CD’s that I have scratched badly. It takes more time to rip but it gets it ripped 95% of the time. If you rip to wma you get encoded files that seem not to be yours when they should be. Stick with mp3’s you don’t have big brother looking over your shoulder watching what you listen to.:smiley:


in WMP there is an option for to “copy protect” the music you rip from cd’s. If you have that option selected, it could explain why you are getting the results you are getting.

This is in WMP, you can go to tools>options. And the the copy music tab. The option for copy protect needs to be unchecked.

To deauthorize your player, you need to connect your player to an open Rhapsody account.   When the player icon appears in the Sources window of the Rhapsody software, right-click on it and select “Deauthorize” on the menu.  Should do the trick!


we’ve got 2 e250R’s and 2 M240 Sandisk players…all use Rhapsody…  One of our m240’s is having this same subscription message, although we may have sync’d the night before… happens after about 10 songs or so play… All other players work just fine with our Rhapsody subscription… What can I try to eliminate this problem on the one player? 

Thanks in advance for help!