Sansa m240 1.0 GB - suddenly No Space, No Files, No Menu & Frozen on "USB Connected MTP"

Hi there, hope someone can help with getting life back into my Sansa m240!

I haven’t used this for a few years, changed battery, it turned on, music played … 157 songs … yippie!!!

Then I decided to add about a dozen music files to my mp3 from my boyfriend’s MAC.  They copied easily; I could play the new music on the computer and the external speakers, BUT, none of the original 157 songs were showing up on the computer … I could see all the new music and 4 folders which had nothing in them.

If I disconnected the USB, I could play the original music, but the newly downloaded music!  I plugged it back into the MAC and all the new music was there and playable.  I had no idea how much music on the mp3 nor what amount I had just copied as none of this showed.

So … for whatever reason, I left it plugged in over night … the next morning I saw this message on the screen:  

 " Not epnough space for music db, please free 8 mb" so I deleted 1 song, message still there, all of a sudden I see another scarier message “No Files”  wtf??  I delete one more song, no difference, I deleted all the new music I added.  Still NO FILES and there are no settings to adjust.

THERE ARE ONLY 3 MESSAGES that it displays:

  1. “Not enough space for music db, please free 8 mb”
     2.“USB Connected MTP” and a circle that is half dark with MTP
  2. “No Files”

I cannot access the menu to change anything.

I have XP loaded in my Virtual Machine but m240 is not recognized.

I checked the C drive on my Windows 7 and IT DOES RECOGNIZE the Sansa m240!!! including the properties.

According to Big Tex’s posts, I shouldn’t update my firmware if it is 3.X.X and mine is 3.2.8A, so I haven’t.

Scandisk has been no help and after a few emails somehow assumed my problem resolved and has closed the file!!

 I’ve tried the crazy steps of TURNING off the HOLD (orange shows)  Pressing the POWER button while plugging in the usb cable, to “reset” the system … nice contortions, but nadda.

I downloaded the Sansa Updater, but it doesn’t recognize my Sandisk in Windows 7 … XP doesn’t see my m240 at all.

Any suggestions to recover the music and get it functioning again, would be appreciated.


Hi. i have the same problem. with my sansa m240

can somebody help me? i’v wrote question to support team. and now waiting for answer.

i cannot format my device… can’t add files… sansa still shows "not enough space for musik DB

Please free 8MB"

sansa updater do not recognize my sansa m240…

sdmx3-iv001 - program can’t connect to device. “Communication error!, Reconnect!”


1 year and no response …  I forgot all about this until your note … buy something else

Try this. Hope this helps.