Sansa fuze will not update track licenses

I must have most ghetto sansa fuze out there because I have had so many issues with mine. I currently have two. I do have the newest firmware installed from sandisk sansa updater program.


When I connect my sansa fuze to my PC in order to update track licenses, add songs, etc. my computer slows down considerably and any access to the internet is stopped. I cannot sign on to my account on rhapsody because internet will not work. And since internet cannot work while it is connected, I have not been able to update my licenses and now they are all expired. Please help!


I took the same sansa fuze to another computer. When I connected it to second computer I experienced no problems. However, when I try to update licenses, the rhapsody program says the function is completed. But when I try to listen to music in the fuze, the fuze tells me the track licenses are out of date. I updated entire library and internal and external drives listed in the pane. I hope this makes some sense. Any help is appreciated.

This is the limitation of Janus DRM.  You must update the track licenses on the same PC as they were transferred from. 

That’s not a fault with Rhapsody, it’s part of the way the DRM system was designed.  Rhapsody’s RealAudio RAX format worked around that limitation, using the e200R Sansa Rhapsody.

As for license updates in the past 24 hours, the Real servers were having issues.  The system is back up today!  Yep, I ran into the same issue, updating a handful of devices last night.

Bob  :smileyvery-happy: