sansa fuze v2 stops copying files

my sansa fuze v2 stops copying files immediately after 2-3 seconds, when I trying to copy files on it in both USB modes…

please help

I have formatted it in many ways , tried on another computer even with another usb cable - same problem there

any suggestions?

Is the memory full?

Tapeworm

no, memory is not full - said that its formated many times

also I noticed that same problems when accessing the micro SD on device, but when its inserted in card reader everithings OK…  - when I try to create a folder on microSD inserted in Sansa, explorer immediately hangs and stops responding and after disconnecting the device it returns to normal state

can it be the problem of cables (have to ones) ?

or port malfunction  on device?

Have you tried reloading the Firmware? (Or are you unable to transfer the firmware file?)

If, by some unlikely chance, your player is under a year old, perhaps you could return it to Sandisk for a replacement.

Could be a port malfunction, yes. And if it is the Fuze is dead.

But I would suggest you format again, reload the firmware, and switch to MSC mode (Settings/System Settings/USB mode). That is the least complicated path to getting music on the Fuze. If it doesn’t work, it’s probably, unfortunately, dead.