Sansa Fuze stuck in boot loop = anything else I can try?

I recently took my Sansa Fuze out and charged it in an attempt to use it - but it appears stuck in an endless reboot sequence.

First, what it does precisely: when you turn it on, you see the word ‘Sansa’ explode and start to re-form into the Sansa logo, but just as the logo becomes whole the screen goes to black. It then stays black for about 1 minute exactly (63 seconds, I think) - then flashes white and starts the whole sequence over again. If left turned on, it will continue doing this until the battery is dead. The computer does not recognize the device in either MTP or MSC mode.

Secondly, what I’ve tried:

  1. Yes, I’ve tried resetting it literally dozens of times - holding the power button up for anywhere from 15 seconds to a minute and a half. The next time it’s turned on (or plugged-in - see #2) it does the same thing again.
  2. There seems to be conflicting information concerning which buttons to use in order to force the device into MSC mode, but yes, I’ve turned the device OFF, slid the Hold switch down to Lock (orange color showing), and tried pressing and holding the left button ( |<< ) while connecting the device to the PC = as well as pressing and holding the up button ( >|| ); the center button; the right button; the down button; and the Home button).
  3. Having failed with the above attempts, I tried buying a new cable - also to no avail.

Is there something else I can try? I’ve read some vague accounts about a special combination of buttons to use during boot-up in order to get the device to self-erase (or reload firmware?), but I can’t locate that information again.

I’m an electronics engineer and software programmer, so if there is some other complex method I can use to reload the firmware or clear what is obviously corrupted memory, I would appreciate the information. But please don’t ask me if I’ve tried doing one of the things I’ve described in detail above.

Addendum: I forgot to mention that I’ve tried the device on a few computers (both under XP and Windows 7). Same results.

I believe there’s information on the Rockbox website, which can help ( I wish I could post a link or repeat what the site says, but for some reason I can’t seem to access the site (perhaps there server is having problems).

Go to there wiki, and look for a “Sansa AMS” section. It describes a recovery method, which is ment to be useed to fix issues caused by installing rockbox (mostly for bricked devices like yours), although I think this recovery method could help here, too.

Here’s the Google cache of that page.

So i recently had the same problem. (DeC 24 2013). I, for whatever reason thought it would be a good idea to defrag my mp3 player? Why I DONT KNOW, bordom maybe. after i unplugged it and watched it start, it reset itself after the flower logo and on and on. googled the problem with no solutions. Thing is,  I could still plug it to my PC and every thing seemed normal, it just wouldnt boot up. So I Ran scandisk on it and that didnt do Sh*T! So I took all my movies and music off and used My PC to format it. Unplugged it and let it start up and voila it booted and I copied all my stuff back over problem solved. Thought this might help someone with this POS player, us the poor and unfortunate. PS- I also tried reseting and hitting it  to no avail, but this worked for me when i thought it was garbage time

I (and many ohters) don’t consider the Fuze as a POS player. And since your problems was admittedly self-inflicted and easily remedied, I don’t kknow how you can honestly say this either.


Yeah, really, if you think the Fuze is that bad feel free to send yours to me. Best player SanDisk made.

Then you can go spend a lot more on a nice doPi player with no radio, no external storage, no recorder, less user control…