Sansa fuze and ubuntu hardy heron

I bought a fuze a while ago and it works great when i use vista on my laptop, but when i switch to ubuntu hardy heron, my computer wont see it. The fuze will say it is connected, but wont charge either. Any suggestions? Thanks

Doesn’t Ubuntu have a USB library?  Iknow you can work with MSC mode.  Be sure that the device is manually set via Settings > system settings > USB Mode > MSC.  The device can have issues if left in Auto Detect.

Bob   :smileyvery-happy:

well, i have tried that and it wont show up. Its as if its not connected when it is.

Have you tried lsusb to see if the player is seen by the OS at that level?  I’m running Ubuntu, and it recognized the Fuze fine first try (as a storage device… had to tell it it was a music player).  If you search these forums, you should find quite a few threads on issues with getting the player to work (semi) correctly on Linux.  One such thread w/some good info is this one:


well, i tried lsusb and it doesnt show up, only my mouse does. It seems my OS is ignoring my fuze lol

well, i tried plugging it in as i turned on my laptop and it said that i should format the device with a proper microsoft fdisk tool. anyone have any ideas with that? i already tried reformatting it.

Since I’m not having any similar problems, I’m not sure what to tell you… Are you plugging directly into the PC’s USB port?  Or, are you plugging into an attached hub?   If you have forced the unit into MSC mode, does Windows still see it in that mode?

i plug it straight into the computer, no hub, and ive tried all the modes, windows sees it in any mode, but ubuntu wont see it period. i think my ubuntu and fuze had a fight without me knowing and are ignoring each other. Thanks for your help though

woooooooooow. i just tried using a 4-port hub to connect my fuze and ubuntu now sees it. its in msc mode. but it doesnt see any of the music. is there a way for me to see the music and everything thing thats on it?

I’m sure someone else can answer you more authoritatively (I’ve only had my Fuze for a couple of weeks) but I believe that any files added via the MTP mode cannot be seen via the MSC mode.  I’ve not been able to see the default songs on my via computer regardless of mode.  Might that be your issue?

Clarification/Confirmation/Contradiction?  Anyone?

that may be the problem, ill check it out. BTW, how do i make it so that ubuntu sees the fuze as a media player and not a storage device?

you need to create a file (empty) in the root of the drive called “.is_audio_player”

thanks, that did the trick. i think everything works well now. Thanks for all the help. :smiley:

my pleasure - enjoy!

Nice to see one more problem solved with the help of the forum :slight_smile:

I had the same problem with my Fuze: Hardy Heron just couldn’t see it nor did it charge. I found the solution here (

Basically run the following two commands:

sudo modprobe -r ehci_hcd
sudo modprobe ehci_hcd
As soon as they are run, the Fuze starts charging and the file browser shows up.

Another thing: If you are using rhythmbox to sync your files, you can put “audio_folders=MUSIC/” in the contents of the “.is_audio_player” file to make Rhythmbox put the music files that you drag into it in the “MUSIC” folder instead of the root of the device.

I’m runnint Hardy Heron now, soon to upgrade to Intrepid Ibex, so just ask if you have any questions.