Sansa Fuze 4GB Works fine but need an answer

Hey guys,

This is my first post here and I am looking for an answer.

I have the Fuze 4GB Black.

It works great and I really love this thing!!!

My problem is probably my own fault but I can’t seem to correct it.

I got it before christmas and I filled it up with as many songs that I could - It was full with only Kilobytes left.

For christmas I requested an 8 GB memory card also by Sandisk, and started adding songs and albums

to it. 

I can listen to everything using headphones, I can get internal and external memory to no end.

I have a radio that has a usb port right on the front and I could go through the entire Sansa files using the UBS cable and play everything.

There was a bunch of numbers that would show up before each song title when I used the radio, so in my infinate wisdom, I decided to “clean up” those numbers and I removed them from my files in the memory card.

I did this through my computer.

Now when I try to listen to the sansa through my radio all I can get is what is in the Internal memory and somehow I do not have access to the external card.

I reformatted the sansa - added songs to the internal memory and still the same.

I reformatted the Memory stick added songs - same issue

I reformatted everything Sansa and memory card and add songs to the card and I can get the card but when I add a song to the internal memory, I lose access to the card.

Also I reflashed the Sansa with the updated 1.02.31 version Same issues as above.

My thoughts on this are: (Man you really F’ed up here), Well that is my initial thought :) 

 Is it possible that if there is open space in the internal memory, that it takes priority over the memory card?

Will I have to buy another memory card?

Is it possible to reformat the memory card and wipe it clean?

I can still listen using the cord and input option but I lose control of file selection through my radio.

What did I do and what can I do to fix this?

I suggest you:

  1. Back up your music.

  2. Format the card to FAT32.

  3. Go to Settings/System Settings/USB mode and change it to MSC.

  4. Transfer music (just an album or two for testing) to card.

  5. See if it works.

My guess is that you have a USB mode problem. If you look at Settings/System Settings/USB you will see Auto Detect, MTP and MSC.

There are actually only two modes, MSC and MTP. MSC makes the unit look like a basic flash drive or disc drive to your computer. MTP connects via Windows Media Player so it can send digital-rights codes, sync, etc. . Auto Detect chooses MTP if it sees Windows Media Player 10 or above on your computer, MSC otherwise.

Here’s the fun part: Your computer can only see one mode at a time. If it’s in MSC, files transferred via MTP are invisible. And vice versa. The Fuze doesn’t care, but your computer does. And so, probably, does your radio.

You need to find out whether your radio uses MSC or MTP, because if files aren’t transferred in the right mode, they may be invisible to that connection.

The numbers added to the folders or files suggest you were going via Windows Media Player and MTP, because it adds those for its own mysterious indexing reasons.

Use MSC, just drag-and-drop via Windows, and things get simpler.  Unless, of course, your radio prefers MTP.

Thank you,

I have everything backed up on my computer and CD so I have lost nothing at all.

When I updated my firmware, I had to put my player in USB mode MSC.

It was however in Automatic when I went there.

I just reformated everything again and I have filled the internal memory up with all the songs that were there before.

I will go to the player and switch to MSC then transfer a song or a small album to see if it will work.

Thank you for the tip.

Second question,

I tried what you said with the MSC mode.

It didn’t work.

I reformatted using FAT 32 and I just switched it to MTP mode.

When I plug it in, it comes up Sansa and shows files in the directory. There is no music folder in the card.

Do I need to create a file called MUSIC ? for it to work correctly?

Here’s something interesting.

  1. I have the instruction book and it says it need to be an MTP device. no problem there I will keep it in MTP.

  2. I have the SHARP XL-DH229N radio/media player. As long as my sansa needs a charge, this radio system reads it. But

when I connect it and it has a full charge, it says “no media files”  I was unable to check my device yet because it has a full charge.

I called SHARP to find out why the system loses the connection when my unit reaches full charge.

It seems that the radio uses the USB port to read things like thumb drives and memory sticks only.

When my unit  (MP3 player)  reaches or is plugged in with a full charge, there is no need to use it’s

power to charge it. The Sharp needs to have power to run something like cards and memory sticks

so it thinks there is nothing plugged into it.

It doesn’t matter where you put mp3 files as long as you don’t put them in folders that get special treatment like Audiobooks, Photos and Podcasts. If you want to start  a Music folder, go ahead, but you could also call it Funny Noises or Wikileaks or anything else.

That’s really wacky about the Sharp and the power. I guess the only MSC devices they expect people to use are passive storage like a thumb drive–which would be MSC. The MTP requirement must be to let the Sharp somehow control the Sansa.