Sansa Fuze 4GB* MP3 Player - Blue - Computer won't recognize

For some reason my computer won’t recognize the MP3 player when I plug it into the computer, like it won’t show up on the screen or in my computers. It once did, then one day it just says the following when I plug it in “The USB Mass Storage Device is a Hi-Speed USB device and will function at reduced speed when plugged into a non-Hi-Speed port…” I have no idea what that means. On the MP3 player when it is plugged in, it says ‘Connected’ and looks like it’s charging but it’s not charging at all. I tried it with my sister’s computer and it shows up on ‘my computers’ and I can actually put and delete songs on it so I’m just confused, if anyone could help me. Please and thanks. :slight_smile: My email is magee__vwj@hotmail.com

PS. I’ve tried almost everything. Or at least I thought I did.

You posted this in the wrong forum (“MP3 Legacy,” meaning older MP3 players). I suggest you re-post in the Fuze forum to get more people seeing this.

I would try two things:

  1. Reset the player (Hold the Power switch up for about 10 seconds). Then see if it connects properly.
  2. If that doesn’t work, maybe it’s your USB port. Try another port. If you’re using a desktop, try a rear port.