sansa express - building database

My sansa express worked for a good couple of months, sudenly yesterday it was not working as always. I went to sansa web site, and I found the forum and the information on how to update the firmware.

The update didn’t work at first but it did work with the workaround instructions. In the process I formated the drive and I stopped by ina store and I bought a 2 Gb Sandisk MicroSD. Later on at home I reloaded all my songs and everything worked perfectly.

This morning when I turned it on, I only see the message “Building Database”, after a couple of seconds the process is not finished ad I can’t use. Hard reset doesn’t do any good. Removing or reinserting the micro Sd cards doesn’t do any good either.

Some of the previous threads about this didn’t help me either.


Just to make it clear. The building database problem when it tries it for some time and later shuts off started after I apllied the new latest firmware. This was not a problem I use to have before.

After removing the hardware previously installed I was able to reload the firmware using the work around instructions. No my music left in the micro SD card shows as expired (music to go). Let’s see if I can load the music and actually be able to listen to it this time (exactly what I did yesterday).

Sorry, just expressing my frustration. I’ll only be able to reload the songs later this evening at home.

As somebody else said before, I wish this things would work without the need of messing around to much to get them fixed, better if they would work right from the box. I do refuse buying an ipod, they may look cool specially the iPod Touch, but I don’t like the fact they don’t offer “music to go” and I don’t like iTunes.

My Sansa Express is working again. After reinstaling the new firmware and not formating the device or the SD card thru the software it’s working. I need to retest the “format” option thru Rhapsody to check if this was the cause after the new firmware or if the download of the songs didn’t finish ok and corrupted the information.

Anyway, the new firmaware works with and without the SD card. By the way, circuit city had a very nice deal on microSD card, what helped me to decide buying one and trying it. I hope it stays working like this.:wink:

How did you managet to install the firmware?

I receive the message and the USB device is not know to my PC…

Hey… i have the same problem can u please tell me what to do exactly to fix it…???

@eltinai wrote:
Hey… i have the same problem can u please tell me what to do exactly to fix it…???


Try reflashing the firmware following the instructions in the attached link.