Sansa E280: WinXP keeps asking for "Tango digital media platform"

Sansa E280: WinXP keeps asking for “Tango digital media platform”

Hey everyone,

I installed Rockbox on my Sansa e280 but now after booting the device it won’t connect to my computer via USB.

I read in another thread it will connect in recoverymode when locked (button on top) and then starting up holding the recordbutton.

Well, then it does connect through windows XP, or Vista for that matter but it tries to install a driver and then gets stuck in windows update when it asks for " tango digital media platform".

Does anyone know how to tackle this problem? I would appreciate very much, because i’ll be off traveling to Ireland within two weeks, acompanied by my favourite Sansa ofcourse…

Please let me know.

Niels

This is from the Rockbox forum, which might have more answers for you.

http://daniel.haxx.se/sansa/e200tool.html

http://forums.rockbox.org/index.php?topic=8443.75

What is Tango  digital media

@tonyalgamble wrote:
What is Tango  digital media

 

A product line of PortalPlayer of which includes the chipset that is on the V1 player.

Don’t 'ya love the cryptic computer responses?  Here’s what’s happening.  The computer sees the chip, and recognizes the type.  Literally, the platform it’s looking for is an operating firmware.

Try to reinstall the firmware before attempting to work with the lower level functions.  The e200 tool rewrites the base (boot) loader.  If that is working, installing the firmware via Recovery Mode is the hot ticket, and it’s a lot safer (and simpler, of course).

Download a fresh copy of the firmware (see the firmware thread).  Place the folder on the desktop (PC), and unzip the contents.

Starting with your e280 OFF, flip the LOCK switch to the right (orange showing), and connect, while holding the REC button down.  The sansa should power up in recovery mode.

On the pc, go to My Computer, and you should see the familiar 16MB PARTITION logo.  This is the actual 16MB reserved partition in the sansa’s memory, reserved for the operating system (firmware).  Drag and drop the two unzipped files into this partition, and then disconnect the sansa.

Now it’s tasty reboot time.  Good luck!  Remember that the UNZIPPED files go into the partition.  If the .mi4 file is under 6MB, it is still squeeeeezed.  Sorry, this is the case with the v2 binary firmware; the v1 is almost identical in size when compressed, 5721 vs 5722KB, in comparison, the v2 binary blooms out to about 16MB!  Be sure to unzip the firmware files prior to installation, as the Sansa will not accept a compressed (zip) file.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 03-08-2009 12:45 PM

I think you missed the part where the original poster can’t load the bootloader onto the device because his computer can not connect to the Sansa and is asking for Tango Digital Media Platform drivers. Any idea on how and where to obtain said drivers o as to enable putting the bootloader and firmware on?

This involves Manufacturing Mode (center button) and the fix as shown in the AnythingButIpod forum.  The I2C rom file and the bootloader are your targets of interest.

Here’s one handy link from above, taken from Rockbox.  I’ll search for the one from ABI, it involves a few ROM dumps…

Come to think of it, if you can get Recovery Mode to display the 16MB FORMAT icon in Windows Explorer, stop at that point, leaving the Sansa plugged in.  Download this from SanDisk:  12a

Run the executable file.  In a dazzling display of Sansa Magic, the application will find your connected v1 Sansa.  It will install the original firmware v.12.  Then, test that it runs normally.  The 12a firmware is missing some cool things, like the Equalizer, so your next step is to update to the version 18 or 24 firmware, and you’ll be back in business.

If you can’t get Recovery Mode to run, then we’ll consider the base ROM issue.

Bob  :smileyvery-happy:

Message Edited by neutron_bob on 05-17-2009 09:31 AM

is there 12a file  for the c240v2

Try the C200 forum.

12a is the firmware for the E200 (or, actually, was the firmware). The C200 has different firmware with different version numbers. 

Message Edited by c1u31355 on 07-16-2009 01:55 AM

Tried this as well…nothing at all.

@trevize wrote:

Tried this as well…nothing at all.

Tried what?

The procedure mentionned above…