Sansa E260 v2 Equalizer Problem (Weird and Annoying)

I have a weird and annoying problem about my Sansa E260 v2. I am using “Rock” equalizer preset and “High” for volume setting. Sometimes (not always) when I start playing a new song (usually .mp3), volume decreases. I set the volume max, but the sound is not high enough. Then I enter the EQ menu, change it form “Rock” to any other and back to “Rock” again and suddenly the volume increases again. While listening to music, always I have to check the volume that it is okay or not. It is a very annoying problem for me.

I tried both v03.01.16E and v03.01.16F firmwares. Nothing’s changed. :frowning:

Is there any solution to this problem? I hope so…

(Sorry for my English.)

Message Edited by commodore on 04-19-2010 05:04 PM

Try the ‘A’ firmware.  Often the E and F firmware have volume caps due to EU law.

Now I tried FW A version but nothing’s changed. :frowning:

The problem not solved.

Is it a problem only on my device or a common E series problem?