sansa connect wireless option not available

When I press the home key and it brings up the menu on the bottom of the screen all I get is “Music Library”, “Photos & Video”, and “Settings”.

These are the only options available and there is nothing regarding any kind of wireless connectivity or setting up a wireless network.  I can see from the pictures on the box that there is supposed to be more icons for connecting wirelessly.

Am I missing something? (yes i am sitting right next to my router with SSID broadcast on)


I had to run the sansa connect recovery tool… (which does not work on x64 systems by the way)

I had opened my device right out of the box and new something was not right.  The recovery tool fixed my menu issue so I can see the internet radio button and it also changed my splash screen to show icons inside of the little round circles when the device starts which it was not doing before.

Hope this is applicable to someone elses problems.  The recovery tool says to only use if the device is giving errors or will not turn on but that was not the case for me.

I just bought one today and my radio button doesn’t show. I even  used the recovery tool,nothing changed.

the connect was desiged to work with yahoo music to go. since yahoo discontinued the music service the wifi music features of the connect were disabled. you now have a regular mp3 player. if this is not what you intended when you purchased it i would suggest returning it for a refund.

Did you run the recovery tool and it actually showed it being restored? The connect was designed to have wifi, I too purchased the device at a great cost only to find “no wifi” on the box. I ran the recovery tool and it did bring the wifi options back. Try it again following the pdf instructions to the letter. The nice thing is that although Yahoo to go is no longer around, you can still listen to the “internet radio” if you have att dsl or att uverse accounts, even if your email is  You can also use if you have a Rhapsody to go account.

Good luck

Thanks, it all works now. I’m not sure what I’m picking up  or where it’s coming from but there is music on there.Any tips?

What a great a great little device.

mmm, did you sync it by any chance to your music library. I seem to recall that it came with a couple of songs already on it.  You can always delete the songs…When I plug into my computer windows media wants to sync but I use Rhapsody to go so I disabled the syncing with windows media player. Yeah, I agree, nice device.

So are you now able to play music from the launch cast?

When I did the recovery it wiped my songs out so I experimented with the internet radio,I scroll down to genres and it tells me I have so many stations in each category to choose from,I pick one, it connects to wifi and begins playing a song. That’s all I know at this point.

It seems rather odd to disable a feature that still works. Why make the customer jump through all of these hoops? Most of us here seem to be tech savvy enough to figure it out,with a little direction. It’s a great little device and a great price but it puzzles me why they disabled it, you can still get free internet radio, that’s a nice feature.

Thank GOODNESS for this Forum!

I also got one of these at a great price and I almost returned it when I discovered the WiFi was disabled.

I ran the Device Recovery Setup and it works great. Nice toy with all the features I have wanted for a long time. I love the images on Flickr…etc…

Interesting … I still have “Internet Radio” on my Connect, and it works fine.

Message Edited by PromisedPlanet on 03-11-2009 10:59 AM

It is my understanding that the only thing that would be disabled when yahoo discontinued that service would be my ability to register and create my own custom radio stations.  My Sansa still works fine with the internet radio and I suspect it will keep working so long as Yahoo is still in business.

That being said, Yahoo has done several things in that past year that seem strange for a company trying to stay in business… like with yahoo mail if you want to use their pop servers you have to pay for them now?!  That is insane and incredibly backwards so I would not be surprised to see this service disappear sometime in the near future.  BUT for now it is working!

Message Edited by asendic on 03-13-2009 11:13 AM

@asendic wrote:


That being said, Yahoo has done several things in that past year that seem strange for a company trying to stay in business… like with yahoo mail if you want to use their pop servers you have to pay for them now?! 


I’ve had a Yahoo email account for several years, and all along, POP access has not been free.


Anyway, I’m wondering if there is some version of the firmware for the Connect that doesn’t carry the Internet Radio (Launchcast) option?  When I first read this, I was nervous about connecting to Launchcast for fear I’d get a firmware “update” that would remove this option.  But so far, it hasn’t happened.


Someone who has a Connect without Internet Radio, could you post the firmware version number?

FYI  Posted the firmware versions for Connect with WiFi disabled as a new thread.

I have run the Recovery Tool because I don’t have WiFi, and when the Connect says it is Installing Software, I get “Image Not Found” briefly, then the Install screen again. However, I do not get the WiFi menus.

I’ve run the Recovery Tool three times now… Any help available?

You have to run the Recovery tool in sort of a “manual” mode. If you run it in automatic mode, it will look for and install the no-wifi firmware (if you have the wifi firmware. If you already have no-wifi, it does pretty much nothing).

You need to carefully follow the instructions in the first post of this thread.

Yes! I found that thread after I posted here…

Everything is working now! Thanks!