Sansa Connect repeated request for yahoo id problem

I have a sansa connect.  When I first got it last month, everything worked fine.  The only problem I had was not being about to use the “to go” feature of the Sansa unit.  This was my own fault as I signed up for the incorrect service initially (YMU instead of YMU to go).  Several emails and a phone call to yahoo support later and I seem to be signed up correctly and to the correct service as verified when I log in to yahoo on my comp. 

However, now my Sansa connect will no longer connect to yahoo at all.  I keep getting the password request screen which I enter and have triple checked that it is my correct password (I am able to log into my account via a comp with the same pw).  After several password entried the Sansa connect displays a message that my portable device limit has been reached.  I only have one Sansa.  My husband has his own with his own account which he is paying for.  I fully intend to pay for my own account when my free trial is up on Nov 1st.  However, I have never actually gotten a chance to enjoy the full free service as I have yet to be able to use the to go feature.  Now my unit no longer connects to yahoo.  Please advise.

I already have done the 20 sec power reset and the full factory reset via the settings menu.  No luck.


Message Edited by tinak on 10-28-2007 04:26 PM

That is new one. Try changing your password on the Yahoo account. Then login to Yahoo! Music Jukebox. Then try Login with the Sansa Connect again.

If that doesn’t work, try the Connect Recovery Tool at

I have a feeling this is something that might need tech support help.


Don’t hold your breath waiting for help. I’ve had a Sansa Connect for three weeks and have never

been able to use it due to problems with the Yahoo To Go! service. SanDisk feigned help at first,

but I haven’t heard a word from them in a week. It’s become obvious to me that SanDisk and Yahoo

are at odds with each other over the Yahoo To Go! subscription service and have left us paying customers

in the middle but of course kept all our money.


Thanks, Greig. Yahoo Tech support or Sansa Connect Tech support?  I can easily predict me being volleyed between the two.  Since I can connect to yahoo on my comp, they might see it is a Sansa problem.  The Sansa folks will want to push me back to yahoo since it is the YahooID that seems to be borked.  Which do you suggest I contact first.

I will try the suggestions you made.

Also, I have initiated another help request via email with Yahoo but hope is waning since they never resonded to my last one despite claiming that it was sent to a senior specialist.  That was three weeks ago.

Message Edited by tinak on 10-30-2007 09:01 AM

Contact SanDisk support.

Provide the following info with the request:

  • Yahoo User ID

  • Yahoo Case# if you have one

From the Connect Settings > Info > Software Versions

  • ZAP version number

  • Device ID

  • System Time ( when you tried to login and get the error)

Out of curiousity, what happens when you enter your password just once?  Do you immediately get prompted to re-enter your password?  Are you allowed to listen to internet radio for a bit before getting prompted to enter your password again?  If you’re entering an incorrect password, you should be notified as such by the device.  Is the device telling you that your password is incorrect?


When I attempt to listen to Internet Radio, the device prompts me for my Yahoo password.  It lists my correct Yahoo id on the screen above the entry area.  I enter the password and then see the “Connecting” graphic for a few seconds and then I am returned to the password entry screen.  No error messages.  Trust me I have double and triple checked it and it is definately the correct password.  I use it to log into my Yahoo account my from my pc.  I only have one Yahoo account.  When I check my account settings via “manage my premium subscriptions” it lists the Yahoo Music Unlimited To Go clear as day.  Occasionally,

I get a message stating that my portable device limit has been reached or something to that effect. 

My “free trial,” which I never got to use, ends today so I guess I’ll have to decide whether or not to go this route.  A shame since I already have the Sansa Connect player.  However, It seems silly to pay for something I cannot use.  No response from Yahoo Customer Support either.

Have you contacted Sandisk support?

If the device recovery tool Greig mentioned above doesn’t help, then it may be time to contact support…


The first time I did this, I had the same problem. Turns out I was using capital letters. The password is of course, case sensitive. Check that, maybe it’ll help.

Greig wrote:

Have you contacted Sandisk support?

I would like to but I seem to have to register again at this site and the very detailed form requires the serial no of the device which I don’t have with me as I am at work.  Maybe this evening or tomorrow.  I have been going back and forth with Yahoo customer service.  They sent a very detail explanation about how I can transfer music from Yahoo Account on a PC to my Sansa Connect which would be helpful, I suppose, if that was the actual problem I was having.  * sigh * patience wearing thin. 

FredFredrickson wrote:
The first time I did this, I had the same problem. Turns out I was using capital letters. The password is of course, case sensitive. Check that, maybe it’ll help.

Thanks, but thought of that already and tried both caps and non-caps.  My pw is all lowercase, anyway.

Just tried the recovery tool.  No luck.  Same problem.  I keep getting asked for my password.  The EXACT same password I use to listen to my internet radio station on my laptop.

I noticed that yahoo had NO problem taking 14.99 out of my bank account for the service I can’t use yet.

Patience wearing even thinner.

Well I solved the problem myself.  I’ll explain how I did it.

I contacted Yahoo support by phone, no help.  I contacted Sansa support by phone, the tech seemed to think the problem was not with the Sansa Connect.  I contacted yahoo support again, no help.  I requested that they simply reset my account and let me start over.  Fine but no refund of the 14.99 I already spent.  I was told to send in a tech request email.  I did and was told in the email to contact Sansa support.  I again requested a refund and this time I got it.

I should also add that I did a factory reset on my Sansa and entered my husband’s account info when I restarted the device.  It worked fine.  I was able to zing songs and listen to his internet radio.  This assured me that the problem was NOT with the device.

With my refund coming, yesterday I started a brand new Yahoo id and opened a new account.  Everything is now working fine.  go figure.  Obviously something was wrong with my original account and yahoo was either unwilling or unable to fix it.

I’m just glad it’s working.  Far too much trouble to get there though.

Thanks to all for the help and suggestions.

Message Edited by tinak on 11-11-2007 07:30 AM