Sansa Connect Goodbye on every command

Has anyone experienced the problem with a sansa connect where the battery is fully charged, but almost every command on the device results in the goodbye message and system shutdown?  The recovery tool has been run on the device and it produces the same result.  Initially, when the device is connected to a PC, a pop up is displayed that says the USB device is not recognized.  However the device continues to load up and is eventually recognized as an MTP device.  The device is then browse-able and music can be downloaded to it, but pressing any of the buttons on the front causes the device to display goodbye and then shut down.  Any suggestions?

I haven’t seen this problem. I’d give the recovery tool one more shot.

Assuming you had this Connect a couple months, Contact SanDisk Support.

Thanks for the advice Greig.  I tried the recovery tool once again, and after some sluggish behavior, the connect appears to be working right.  Thanks again.

Message Edited by morning_star on 09-26-2007 01:52 PM