Sansa Connect does not go into menu

 I was transfering about 600 songs into the Sansa Connect with windows media player 10. When i got to about the 309th song it froze and i stop it on the media player. Then i resumed it again and it didnt even start it stayed right where it froze. After that the Sansa turned off and when its turning back on it stays on the first screen where it says Sandisk in white. I have tried fully turning it off by holding the power botton for 8-10 seconds and 30 seconds, it still doesnt work. Then i tried putting it on recovery mode by holding the volume up, right on the scroling wheel and the power botton after turning the connect completly off. It never goes into recovery mode and i dont know if its because im doing it wrong. Someone please help me with this i have had this Sansa Connect for almost 1 year now and never had this type of problem.

have you tried this

Download Sansa Connect Recovery Tool

How to use the Sansa Connect Recovery Tool   (.pdf) 


Thanks much for those links.  I just used them to fix a “freeze” type problem, where my Connect would only go between full power off and displaying the 5 balls–it would not get past the 5 balls.

drlucky  Thank you for the link on how to use the recovery tool that was my problem i was using wrong.