sansa connect 4gb not charging

Hi everyone i hope someone here can help me out! I have a connect and it chrged yesterday with usb and a wall chrger but today it will not charge at all!Any ideas? I have reset to factory defaults and tried several usb ports but still no joy!

Did it lose its charge on its own since you charged it yesterday?  Or did it lose its charge due to normal usage?

What happens if you try to charge it with the wall charger, now?

Same thing is happening with my Sansa.  When I have it plugged into the wall it turns itself on over and over instead of charging.  I leave it overnight and the next day its on and the battery is drained.  My sansa has never charged when I use the usb cable to my PC.  I tried today holding the off button till it **bleep** down not just said good bye and 10 seconds later it starts back up again.  Needless to say Im on the verge of buying a new player/cell whatever but if I had to decide right now I would not buy another Sansa after …

DUH!!!  I just tried switching the wall adapter my sansa plugs into by usb and I must have mixed it up with my charger for my bluetooth because now my Sansa is charging fine.  There was no issue with the bluetooth when it was on the wrong adapter, my sansa has never worked in my car on the usb converter I use with the rest of my electronics.  So if your ploayer isnt charging make sure you have the fat square wall adapter Sansa was sold with.  I have gone bananas for months over this, then it took me 30 minutes to register, then I figured out my own my problem! 

You can try to do a recovery tool as well and make sure that you are using the right charger for you device. :wink:   

i have a sansa connect mp3 player and its not charging its keep turning on and off instead of charging i tried other wall chargers and nothing

This sounds like the same problem fyijacque  was having 10 years ago in the posting above.

This player has been discontinued & out of production for about the same time (10 years).

Additionally, there is not even a user manual or firmware update posted anywhere here on the forum or on SanDisk’s support page on their website. It is essentially, the orphan child that has been forgotten.

If the solution posted by fyijaque doesn’t solve your issue, the only thing I can recommend is give it a decent burial (recycling) and move on with another newer model. Nothing lasts forever.