Sansa Clip

I have media player 9 and no admin rights to install/download media player 10. Are there any work arounds that anyone can suggest to allow me to use this player?

Never fear–set your player to MSC mode (Settings/USB/MSC); but note that this will not work for playing DRM-protected files.

If you have an older version of the Clip firmware without that setting, put the Clip into hold and press the center button down while connecting the USB cablw between player and computer–this forces MSC mode.  And then upgrade to the latest firmware (see the thread at the top of this forum) so you can permanently set the setting.

Welcome!

Never fear–set your player to MSC mode (Settings/USB/MSC); but note that this will not work for playing DRM-protected files.

 

If you have an older version of the Clip firmware without that setting, put the Clip into hold and press the center button down while connecting the USB cable between player and computer–this forces MSC mode.  And then upgrade to the latest firmware (see the thread at the top of this forum) so you can permanently set the setting.

 

Welcome!

 

Can I download the firm ware with out admin rights? Also I got to see the clip by doing your suggestion (thank you) but I could not see my music I had on the player via Media 9.  Will that be an issue or am I doing something else wrong? 

Don’t know about the former.  Strange as to the latter.  You might have been connected in MTP mode earlier–songs transferred when in MTP mode don’t show on the computer when you’re connected in MSC mode, and vice-versa.  But it all shows on the player, and plays.

one more thing if I may please. downloaded firm ware latest version.  it updated…but for some reason I have chinese language need to go back to English Help!!

Did you use the U.S. version of the software?  I believe an earlier post said to reapply the firmware (I would imagine, use the U.S. version for English language) and the language will reset.

Another question pls.  My Sansa Clip is only recognized if I boot up with it in the USB.  It will not recognize if I attach it after I am booted up.  Is there another fix?  Again thanks for all your help. :smiley:

For the language thing, to correct it:

Go to Settings in the main menu (picture of the faders)

Scroll until you see FM (no matter what language you’re in, FM in FM Settings can always be seen)

When you have FM highlighted (not selected, just highlighted) go up by one and select it, then English should show up as english.

As to the Clip only showing up when its plugged in while booting, that’s pretty strange. There may be something interfering with the player being initialized once the computer has all it’s programs running. Do you have rhapsody, music match, or Kodak Easy Share installed on your computer?