sansa clip

My kids just received two sansa clips for X-mas and both have froze on the scan disk welcome screen. I have tried to reset the devices by holding the on slide for over a minute. I have tried doing this from cold and plugged into the USB. I am running a Macbook pro G4 with USB 2.0. I have OSX 10.4.11. One of the units I was able to copy over about a gig of mp3’s then eject the device like all mac devices. I waited a good long time after the Icon was gone to unplug the device.

I plugged the devices into my sister’s Vista computer and they are not recognized either.

I feel like my sister was ripped off and lied to that the Sansa clip was cool to use on a Macintosh.

Any help would be great.

Help fix a sad X-mas

For MAC, when you plug device in, it automatically changed to MSC because MAC don’t support MTP.  As for PC, it supports MTP so the device autoselect to be in MTP mode.  If you want both to work in both machines, either upgrade to the newest firmware to get the option of having the device always in MSC mode or you can try this trick with older firmware: put device in LOCK mode by slide the power button backward and press-n-hold the center button while plugging in PC.  Hope this helps.