Sansa CLip Zip will not receive music. Please Help

Okay so I bought a Clip Zip from Amazon. It was a refurbished model, but I have been using for about two weeks now.I use Rhapsody to download my music and the other day I downloaded some more songs onto my playlist. I plug the Clip Zip in and the progress bar at the top says transferring songs etc. then it says its done syncing, I look on my player and it didnt add the new songs. I figured it must have glitched. I resynced it but this time it synced in literally 3 seconds. IMPOSSIBLE I added like 30 songs. Yet again the songs were not on the player. So i formatted the player resynced and now NONE of my music from that playlist will go onto the player. It says its transferring but the storage space bar at the top never changes. Ive uninstalled and reinstalled Rhapsoidy, and the Sansa Updater, I’ve used different usb ports, and cords.Ive even gone and updated the drivers reauthorized the player and the computer. Ive reset the Clip Zip and still nothing. PLEASE HELP!!!

I am having exactly the same issue. I’ve tried multiple times on multiple computers and even though it looks like its synching and downloading/transfering the tracks, once I dismount the player and look on it, there is exactly one song on it – even after hours of watching tracks appear to download in Rhapsody’s Sansa Clip Zip window. (Track names pop up and a progress bar appears with ever-increasing percentages, then the next track name with the same). Everything looks like it’s working, but no tracks get transferred.

I wish I could help, but at least you know you are not alone. I’m planning to complain to Rhapsody, because they need to know that they are recommending this as a compatible player when it doesn’t work! Like you, I bought a reconditioned Clip Zip from Amazon.

I have never used Rhapsody, however I have a feeling Rhapsody probably uses protected files, in which case the player needs to have its USB mode set to MTP. To set the USB mode to MTP, on the player go to settings, system settings, USB mode, >MTP.

Yes rhapsody uses protected files. I have tried the clip in msc and mtp mode and auto detect neither work. I’m thinking it’s an internal software issue with the clip itself. When I transfer the progress bar tha shows the clips storage space doesn’t move at all. It’s as if something inside the clip is blocking data from getting in. Then I’ll look inside the clip via my co.puter and I see the music files burl when I open them they are totally empty. This is so infuriating!

Just wanted to let you know, the same exact thing is F&%$!%& with me too. The only difference is that I’ve had my Clip for a year now and it’s been working like a charm. The date on your post is within a day of when mine hit me too. I’ve done everything you did to try and get it back. Now I can’t transfer anything to my Clip anymore. I’m wondering if it might be something with Rhapsody. They had a software update right around that time too. I haven’t sent anything to them, but we should be bombarding both Rhapsody and Sansa to see who/what is the issue. I’ll keep watching this post to see if anything gets resolved. Hopefully we can figure this out together.

Perhaps you might need to reinstall Windows Media Player, then be sure to have the player set to MTP mode. 

Windows Media player includes the MTP drivers with it.

It’s not through WMP, it’s through Rhapsody. With the Sansa Clip(s) you can create playlists within Rhapsody that you can then transfer/download directly to the Clip. It’s all done within Rhapsody’s software. 

“It’s not through WMP, it’s through Rhapsody.”

Yes, however if there is something wrong with your MTP driver, protected files are likely not to function properly. Windows Media Player contains the MTP drivers. I don’t know how to download them separately, although there might be a way to do so. of course you need to have the USB mode on the player set to MTP to get protected files to function properly. 

One other thought I just had. Some protected files might only work on the Sandisk players if they are in main memory and not card memory. Were you trying to transfer the files to main memory or card memory? Perhaps Rhapsody might not even allow a transfer to card memory, or even if it does, the player may not allow Rhapsody files on card memory to play. As I said before, I never used Rhapsody or any other protected files, however I have heard others say they couldn’t get certain protected files to work on card memory, only from main memory.

I am having a similar problem using my Clip Zip with Rhapsody. It worked fine for a long time but then when i tried to play a song my Clip Zip says “Synchronize to continue your music subscription”. I’ve done that multiple times on Rhapsody and it says I am synched for another month. The Clip Zip also says it is renewed through that date. However the error message continues to occur everytime I try to play something. Very frustrating since it happened all of a sudden a couple of weeks ago and has continued ever since. What are we paying for when we can’t listen to the Rhapsody music?

OK, here we go. I sent an email to the Rhapsody tech peeps to see if they would even respond. To my surprise, they did, and in a big way. I’ll clip in what their response was to see if it will help anyone else on this thread. Thanks everyone on this thread for trying to help us out! Here’s the email from Rhapsody:

I am sorry, you have issues with transferring songs to your Mp3 player. Sure, I will help you.

To solve the music transfer issue on Sansa mp3 player. You have to update windows DRM components through windows media player by downloading song to computer in version 6 software.

Please follow the steps given below:

1. Launch Rhapsody PC software and sign in to the account.
2. Connect Sansa mp3 player to computer.
2. Find a new song on Rhapsody PC software
3. Download to computer by right clicking on that song
4. Minimize Rhapsody software
5. Go to the download location and find that song on the computer hard drive
6. Play that song through Windows Media player
7. Wait until you get a prompt to do the security upgrade
8. Click on Yes and Upgrade it
9. Click on close once it is upgraded
10. Now, try to play that song on Windows Media Player
11. You can close Windows Media Player
12. Now, try to transfer songs from Rhapsody software to Sansa mp3 player and see if it works.

I followed this exactly, and everything works as it did before. I can download/transfer any and all songs now. I hope this helps for everyone else.


Thanks cwinkm, it works.!!!

Thanks! I’ll give this a shot and let you know if it works for me. (By the way, I’ve had multiple e-mail exchanges with Rhapsody support people, but for some reason, they hadn’t offered me this solution.

Better late than never, though, so thanks! I’ll let you know if it works.

Big help!

After reinstalling Rhapsody, uninstalling Rhapsody 4.0, deauthorizing my computer, my device, taking out the micro card and re-installing it, reintalling the Sandisk installer–this was finally the solution that worked.

What a royal pain in the neck.  I appreciate your information and your post.

Sandisk and Rhapsody should post this on their sites.  

Thank you! Worked like a charm. Really a shame but it is fixed. I have spent endless hours, bought a new player not realizing it is not compatible (arghh!)

I really appreciate that you posted this.

Thanks cwinkm for sharing.  This worked perfectly!  I had spent days trying to resolve and devoted hours trying solutions suggested on the Internet. Nothing worked until I came across your post.  Very happy to finally have the problem resolved.