Sansa Clip+ Reset Failure

The player won’t let me delete files from my device nor allow me to add new files.
I updated the firmware.
I tried soft resetting, then hard resetting.

Then resetting from the settings options. The player would show that it had been reset and the device is empty. When I plug it in all the files I deleted are there again.
I tried formatting from my computer but that didn’t work.
I’m not sure what to do now. Any advice?

Did you try formatting from the player’s System Settings menu?

Yes. I successfully reset using the system settings on the device. Several times. It works until I turn it off and turn it back on, everything is back on the device.

It wouldn’t let me reformat the disc from the computer though, it stops midway through the attempt. 

Did you reset or reformat on the player (both under System settings)?  A reset will not erase user content, a reformat will.

You could try running ChkDsk on the player’s memory in case there is some corruption in one or more files that is preventing formatting.

Did both

Maybe some advice at this webpage may help? (Skip “Method 1”)