sansa clip plus and itunes - how to transfer files

I am really ignorant, but would be most grateful for some help.   I’ve done searches here re this topic but don’t understand the answers given…

Basically I use itunes on Windows XP.  I’ve just boughts a Sansa clip plus.  

I don’t even know what type of files I have in itunes - they are mostly ripped from cds. I presumed they were mp3s but looking at past postings here it looks like they may be something else (ACC file extensions?).   Anyway I’ve been fiddling around in itunes but have not been able to verify what the files types are ('cos I am that ignorant!!!)

Earlier today I simply copied some of the songs in itunes, went to Windows Explorer, and pasted them into the music section of the Sansa Clip file.   They played fine…

I then went and deleted those files on the Sansa Clip Plus, as they were just an experiment.  

I then went back to itunes, and copied more files.   This time, when I went to paste the files into Sansa Clip Plus in Windows Explorer, I found the paste option was greyed out.

I am stuck, and would be incredibly grateful for some help.   As you can gathered from the above mess, any guidance I get needs to be pretty basic.

I use iTunes all the time - chances are that your files are simply in the wrong format for the Clip.  It is pretty simple to fix.  Keep in mind, though, that I use a Mac, so some of these things might not be the same.

  1.  Go to the iTunes Preferences menu (iTunes - Preferences)

  2.  Click the button called “Import Settings . . .”

  3.  Select the import method you prefer (for simplicity sake, you can choose “MP3 Encoder”) from the “Import Using” drop-down menu.  You can then choose the setting (quality).

  4.  Once you have done that, go back to your music files in iTunes.  Highlight all the songs you want to convert, then either right-click or open up the “Advanced” menu, and choose “Create MP3 version.”  Depending on how many files you selected, this may take a while.  A new temporary “Converting” playlist will appear in the sidebar, so you can track the progress.  Once this is completed, you will then have MP3 versions of your music which you can easily drag and drop into your clip.

The new MP3 files will be in the same folders as the other formats, so make sure you grab the right files to copy to your clip +.  One thing to keep in mind is that you can’t create playlists or sync from iTunes - it will only work with iPods.  

I hope this helps. 

Hi DrMike - thank you so much for your suggestion… but regrettably it didn’t work.  

I went to iTunes>Edit>Preferences, clicked the Import Settings tab, and changed the setting from AAC encoder to MP3 Encoder.   

I then highlighted an album’s worth of songs.   Right clicking didn’t bring up the option to convert, so went to the “Advanced” men and chose “Create MP3 version”, as you suggested.  

Under each original song there appeared a duplicate.   There was nothing on my iTunes interface (that I could see) to tell me either what the original file types were, or what the new file types were.   I just presumed that each new duplicate was an MP3 file.   

When there was a full series of duplicates showing on the screen  I copied them.  

I then opened up Windows Explorer…Sansa Clip +…Internal Memory…Music.   I right clicked to paste in the new files, but again, the option to paste was greyed out…

I am still not fully convinced that the files in my set up of iTunes are not MP3s.  Can it be that the person who guided me through setting iTunes on my computer up in the first instance organised that they would be registered as MP3s?   It seems odd that the first time I copied and pasted the files (an assortment of completely different tracks of jazz and classical music), that they all transferred fine - I guess there were about 4 or 5 in total, but they all played perfectly on the Sansa Clip+…   It was only when I tried again later that I had problems.  

Thanks for trying to help though, I really appreciate it.

the easiest way is just to use windows explorer to look at the files. go to documents, then music. in the music folder there should be an itunes folder. this is where itunes will store all the files. you will need to set the computer toshow files extensions for know file types. find your MP3 files and copy them from windows explorer then paste them to the clip. 

Many thanks drlucky - that was very helpful.

I looked at the file types in my iTunes folder.   Some were described as MPEG Layer 3 Audio, others were described as MPEG Layer 4 Audio.

I copied and pasted 2 albums of the MPEG Layer 3 Audio type to my sansa clip + without any problems.   I copied a 3rd album of the MPEG Layer 4 Audio type as well.   That *seemed*to go in okay, except that the name of the artist did not appear, nor did the name of the album.   When I played the sansa clip + only the first 2 albums were showing.   The 3rd album wasn’t there.

I’m guessing I will need to set up a separate thread about getting these MPEG Layer 4 Audio files into the sansa clip plus. Presumably the first lot were MP3s, and the final album had songs that were not…

Okay, I finally got round to googling the difference, so no more elaboration needed…

Hello drMike. I have been having similar problems and your solution was inch perfect for iMAC.

Its a a good iMAC but when everything seems Windows bias, life can get .teejus’. Happy New Year


There is nothing like a clear, concise,correct and complete post that works!

thank you very much!


I have found if you drag the icon to the desktop you can see whether it is an .m4a or a .mp3 extention.  I have found that it works fine, however, I am running into another problem. For each song I transfer, I am getting a junk file that has a period (.) and an underscore (_).  These junk files are just there, they don’t play, but they do affect the counter telling me how many songs I have.

I was wondering if you see these junk files show up.  For example the song Imagine would look like this:  ._imagine

Very annoying. 



You can also use Hidden Cleaner to remove the Finder files.