Sansa Clip+ not turning on, power button broken

I have had my Sansa clip+ for 2 years now, I dropped it and the power button doesn’t work

I have been plugging it in to turn it on and it has worked for about a year

I in the middle of listening to a song when it just cut out and turned off

plugging it in to an outlet or to a computer wont turn it on, both computers I tried wont sense it

Please Help!

It may be defunct, but try holding down either the << button or the center button while connecting. 

But if dropping it broke an internal connection that may be the end of it. Or the battery may be R.I.P.

You can find refurbished ones on Amazon (including ones sold through itself, not a third-party seller)  for about $30-$35, though, so it’s not too bad.

You might try leaving it alone for a bit and then come back to it–these little buggers have been known to come back to life.  Including after having been connected to a power source for a few days.

You also could carefully pry it open and see if any of the obvious connections have come undone–e.g. the leads to the battery.