Thank you. 

Since my desktop computer (Win XP SP3) does not currently recognize my sansa clip+, it is difficult to format.    My laptop (Win XP SP3) also does not recognize the sansa cip in its current state.  


I let the battery rub down, I removed the micro SD card, I plugged the Clip+ into my computer and it was recognized.  I just formatted it.   Thank you very much! 

I am having the same issue - my clip+ totally stopped working. Resetting has not worked, nor has leaving it plugged in to my computer for days. I have been trying to get in touch with Sansa to organise a return (I bought it in May) but have had no response - any ideas folks?

I love my clip+ but am disappointed at not being able to use it and am not getting any customer service…


Did you telephone SanDisk?  Often the fastest way, better than email.  In the U.S.:  1-866-SANDISK (726-3475).  And other SanDisk contact information: sandi

I tried holding down the power button for 20+ seconds and it worked!!

Still, this kind of pisses me off because I had one I bought previously and it had the same problem.  I figured it was broken so I threw it away and bought another one with a 2 year warranty - all to find out all I probably had to do was hold down the power button for 20+ seconds!?  grr!

That old sandisk I had - I grew partial to it because I used it everyday for a couple of years!  Hopefully the company will start informing people about this “reboot” thing with the power button because it’s a waste of money to throw away something that obviously works!  Maybe the company has issued a statement or has it in the instructions - in which case I’m an ass - but if they don’t then please do so!



@bwidger wrote:

I tried holding down the power button for 20+ seconds and it worked!!


Maybe the company has issued a statement or has it in the instructions - in which case I’m an ass - but if they don’t then please do so!


The reset procedure is documented in the User’s Guide.

1 Like

:smiley: Excellent tip. I was about to buy something else as well. In my case I had to press for more than 20 seconds…

45 seconds may be BUT it worked! Complete ressuscitation of the patient!

:wink: I am recommendidng you for the post of  SanDisk chief engineer :wink:

Thank you!

THANKS for this thread. I signed up just to post that this really worked.

I was upset when my Clip+ just turned itself off and the power button did nothing. I attached it to the wall charger which always turns it on and again it appeared to have no power.

I held in the power button for at least 20 seconds and let go then I pushed the power button again and it sprung to life. I powered it off. Just to be sure, I plugged it into the wall charger and it powered on again as if nothing had ever happened.

I always assumed my Clip+  would eventually stop accepting a charge so I was prepared to use it in the future plugged in. I just never imagined it would appear to die completely so I could not use it at all.

Thanks…holding down the on/off for 20-30 worked for me…was worried.

Good thing to read the user manual (see the link for it at the top of the forum, in one of the sticky threads), which covers the reset procedure (and lots more!). 

Great, it worked! Thanks for your tip!

My Sansa Clip was fully charged, but just stopped playing. I discovered that I had a disconnect in the wire from the Clip to my headphones. If I wiggled the wire around the music would come back on, then go aff again when I released the wire.

Hope this helps som of you. Victor

thanks i just held it for 45 sec let go and pressed it , it turned on yippie

Similar problem:

Clip+ froze after taking off charger - showed steady logo. Does not go to menu screens. (Checked, not locked.)

Reset numerous times (this used to work).  When turned back on, screen shows steady logo or flashes between logo and “Sansa”. 

Turned off Clip+ and plugged in to pc.  Is getting power because Clip+ turns on, in either of the steady (logo) or flashing(logo/“Sansa”)  modes just described.

Not recognized by pc:

  • Does not show up in file manager (Windows7)

  • Sansa Updater says “No updatable Sansa product has be recognized. Plug in your device and wait for more instructions.”

Checked cable

  • Cable works with a borrowed Clip+

  • Same results with another cable

Checked USB, same results on other USB connections and on another PC.  Borrowed Clip+ works fine on original cable and USB port.  Left Clip+ on the charger for 2.5 hours to see if that would make a difference, it did not.

I also tried the force-mode trick about nolding down the menu key while connecting to the USB with no change.

I did not push a pin into the microphone. :slight_smile:

 (Cannot update firmware or re-format, since I have no menus and no access via PC.)

I doubt whether the files loaded are corrupted - they are DRM-protected audio from a public library and I have checked out all of them before.  I also ran them through a virus checker before transferring them.

Ideas, folks?   I can’t get through to the support phone line.  Maybe there is a lot of traffic after the holiday.

I just hold down the Power button for 20 seconds and released it. After a couple of second tried again to turn ON and it worked !!

You saved me! Mine went suddenly dead and I was already out shopping for a new one. The reset thing worked.

I don’t understand how it just suddenly died. It was sitting on my desk while I was listening, no contact and then nothing.

Glad this forum came up first or second when I googled clip suddenly stopped working.:smileyvery-happy:

I have two Sansa Clip+, and both do the same thing. They are both the 8GB models, and both have Sansa 32 GB micro SD cards. I set them to “Play All” with shuffle turned on. Files are mp3/flac/ogg, all tagged properly & replaygained. I start them playing, and sometimes they will work for hours, other times only a few minutes, either way…they stop playing, and no screen readout, they are completely off. I have reset them dozens of times, I have pulled off the music from the cards & reformatted them…all to no avail. Searching on this topic always brings up the same “answer” - just hold the power button down for 20 seconds to reset it". Well yes, it DOES  get them to work , but only until it happens the next time, which is often 3 or 4 songs later.

What is the actual CAUSE of this issue?? What can Sansa do to FIX it? There are dozens of comments about this issue both in this forum, on Amazon, and elsewhere. But there never seems to be an end solution to this problem. I have always used Sansa players, from E280, to Fuze, to these two Clip+. I am so frustrated about this right now, I spent a lot of my time in the car, so having music at my fingertips is essential for me.

Candidly, SanDisk seemingly has not been paying attention to the Clips for quite awhile, now, unfortunately, and does not seem likely to change now . . . . :frowning:

well then, that is a real drag, as this little thing has such a great form factor & featureset. I used to be a die hard  Rockbox fanatic, but with these, they seemed to have everything I need in the OF. Too bad San Disk drops the ball & ignores it’s customers.

This is most likely the last time I’ll be buying one of their products.

Tried formatting the unit, put  all my album folders on the root of the micro SD card, left the internal memory blank, & just tried to see if having only one place for music, it might keep working. On the way home today, after two days of perfection, it just stopped & shut itself off again.

I returned my 2nd one back to Newegg for a refund.

I am done.

Gremlins sometimes strike the Clips.  They often come back to life just as strangely, even just 1-2 days later.