Sansa Clip+ Firmware Update 01.02.18

Hi All:

The auto updater does not work for me even when right-clicking and selecting “Run as Administrator”.  I’ve downloaded the manual bin file but don’t know where to put it.  (I don’t understand what the term “root directory” means.)   When I click to view the Sansa files I see only one folder called “Internal Memory”.


Just found my answer with a bit of searching.

The “Internal Memory” folder is the root drive.

The Auto Updater really isn’t needed–it just sits on your computer eating computer resources (albeit, very lightly).  Instead, you can simply come to the forum here every now and again and see if there is any updated firmware, almost certainly the only thing that would happen at this point.  But even there, it is likely that there will be no further firmware updates for the product at this point. 

I got a new clip+ to replace an old clip+ that broke. I use it it my car and my old one would continue where it left off when I turned it back on. The one one doesn’t. I have to start back up.

How would I go about downgrading to an older firmware?

You could go back to an older firmware by manually installing it. You shouldn’t have trouble with the resume feature though with newer firmware. Are you pausing the player before turning it off?

I never did with the old one, I would just turn it off mid play and it would continue when I turned it on. Thats why I loved it so much.

I’m a bit coonfused, as this functionality remains–that’s how mine operates.  Maybe a latest firmware that I never got around to installing broke this?

I think I’m still running .15 firmware on mine. I saw no need to update in any of the newer versions.

And it works just fine. :wink:

When I connect to the PC (Win 7 Pro), udpated comes up and downloads 1.02.18 and says update is complete, but device still shows .15 after many attemtps both via updater and manual. 

Also, in Win 7 a window comes up showing the battery level, and it’s not reading it correctly, says it’s “critically low” even though on device it shows that it’s charging up properly.  Could these issues be related?

No, the issues are not related. The “Critically Low” error message is a known Windows 7 bug. Micro$oft apparently doesn’t think it’s worth their time fixing.

Are you downloading the firmware version from the 1st post in this thread? Are you sure you are un-zipping the .zip file first and then placing the .bin file contained within in the root (top) directory of your Clip Zip? After you do this, are you un-plugging the player? It should turn off. When you power it back up, the screen should say “Firmware Update In Progress” or something to that effect.

Ah, ok, thanks for the heads-up on the error message. Not a big deal, just annoying.

And on the update, yes, unzipping and placing in the root. But after I unplug the player, it does not turn off. It stays on and screen says “refreshing your media”. 

Again, I don’t think it’s a big deal, it seems to be working fine with the previous version, so I’m not too worried about it.  Thanks for your reply, though.

Hi guys,

I just updated my Clip+ to firmware V01.02.18A (it was 17A before the update), hoping to fix the issue I have, but it doesn’t. :cry:

I have a couple of new albums, that don’t show up as Artist / Album, just “Unknown”. All of these albums have in common, that they use ID3v 2.4 mp3-tags, my other recordings have <= ID3v. 2.3.

Is there going to be a new firmware for my device, that fixes the issue I have?

Thanks a lot


Sorry to tell you this, but unlikely to be further firmware upgrades–just been too long.

But an easy fix:  just import your problem albums into MP3Tag (Internet freeware) and change the problematic format into the non-problematic format.  Voila–in just a few key presses, it’s done!   :slight_smile:

I had the same problem of Oscaribo and MDeB: a FLAC album continued to frozen at the end of track 6… I have just downgraded to 01.02.16 and the problem has gone :dizzy_face:

I hope that Sandisk engineers are aware of the problem and will fix it as soon as possible.


I’'ve had a similar problem for a while.  Whenever I have a large number of FLAC files on my Clip+, it will freeze/reboot randomly.

My solution was to reformat the device memory and hope that fixed it but since you had some success reducing FLAC-related freezes by downgrading your firmware, I’ll try that first.

I can always do a reformat if that doesn’t work.

After upade my SANSA clip+ to 01.02.18A my device is crushing, shutting off (battery 80%) and freezing.

How i can get the old version i bought my device with?

israel, sansa clip+ 8GB.

A repository of firmware:

I downloaded the “updater install” exe file, but when I double click and choose run, nothing happens.

I run a Windows 7 machijne and have administrator rights.

Why won’t it install?

-Jim D.

You don’t need the updater.  Don’t bother with it.

In the post that starts this thread, follow the Manual Install instructions, which are roughtly:  Download the latest firmware (look for an All Regions link), which is a .zip file. Unzip it. On the Sansa go to Settings/System Settings/USB Mode, write down which mode you had it in and change it to MSC.

Open Computer (otherwise known as Windows Explorer) and connect the Sansa to the computer. Drag the files you unzipped directly onto the driveletter for the Clip. Disconnect it (by taking the connector out of the Sansa first, not the computer) and it will update.Change the USB Mode back to what you had before.

The updater tries to contact Sandisk every time you boot up to see if there’s an update. All that does is slow down your startup.  If you’re really worried about missing an update, check in here every now and then–but as you can see from the initial post, there hasn’t been a firmware update since August 2012, which means it’s pretty unlikely there will be another.

1 Like

Thanks for this info!!!