Sansa Clip 4gb is not being recognized


I bought my sansa clip 4gb a few months ago.

This week I connected it to my usb port, as usal (the computer is the same… no formatting… no environment changes… no updates!)…

but the device is not even mounted!!

  I only get the charging progress in the screen. (The battery can be charged)

I’ve also tried to use another wire, another usb port, to change usb connection to MSC… and all the recomendations i’ve found here at the forums… and I’ve also connected it to 3 different computers, but nothing…

How can i do to make windows recognize it again? i suspect is a hardware problem. 


Buenos Aires,

I had the same problem this weekend.

New Clip 2G.

Works on one computer, but the other computer–the one my kids will be using–does not recognize it. I tried every USB port.

It will charge though.

Well, i had that problem the very first time i plugged it.

Installing Windows Media Player 11 the computer recognised it inmediatly.

Try with that …

Unfortunately my situation is different…:cry: