Sansa Clip 01.01.29 ogg support, database shows "unknown"

Hello, I’ve installed the new firmware and copied over some ogg files.  The files play great, however the database doesn’t appear to be picking up the ogg tag information.  Has anyone else encountered this?  Thanks!

http://xiph.org/vorbis/doc/v-comment.html says comment field names are case insensitive, but firmware 1.01.29 seems to refuse the ones spelled in lowercase letters, e.g. “artist=Foo Bar”, “title=Bar Boz”.

Try making the comment field names uppercase as a workaround, e.g. “ARTIST=Foo Bar”, “TITLE=Bar Boz”.

That worked, the program that I use to convert flac to ogg uses Mutagen which deals with the case insensitivity by storing all tags as lower case. Looks like “Rockbox”, “IRIVER”, AMAROK, WINAMP, etc. deal with this issue correctly. I’ve submitted a bug request and will report back here with the results. Thanks for the tip, would have never of thought of that…

Whoops! Sounds like Sansa needs to insert a toupper in the C code at next release

Something like this:

pTagField = strtok (pTagString, “,” );

needs to be recoded as something like this:

pTagField = toupper (strtok (pTagString, “,” ) );

:wink:

I was disapointed to see this too. I guess the only solution is to manually add an upper case tag.

Message Edited by Lucky_Luciano on 05-22-2008 04:23 AM

Next firmware will fix this bug.

What (freeware) program can be used to make the field names upper case? I’ve tried a few tag editors for ogg, and they only allow changing the tags, not the fields.

I used vorbiscomment for this.  E.g.

 vorbiscomment -a -t ’TITLE=Lorem Ipsum’ file.ogg newfile.ogg

Wow. That’s tedious. Having to change them is already a PITA, but doing so individually by command line is the most work-intensive method I can think of. Anyone know of a better way, like a windows GUI-based program with batch processing?

EDIT: Ok WinVorbis is apparently a GUI front-end for vorbiscomment for windoze, Vorbix is the linux equivalent.

To make it work, open an album folder and under options create 3 user-defined tags as “ARTIST”, “ALBUM”, and “GENRE”.

Then go to the first track and enter the artist, album, and genre info, then click the “Copy to all tracks” button and save.

Message Edited by batook on 05-24-2008 09:57 AM

Yes, it is a major pain.  Let’s hope they get the firmware update published soon!  I think it was great news they understand the problem and are working to fix. 

I bought a Sansa Clip yesterday and have already written Perl a script to fix this problem on my collection as I can’t wait!  I have a massive collection of hand ripped and pedantically hand named OGGs so getting it right is important to me.  Read: I’m a hapless nerd.

I have run this over several thousand albums in my collection without any errors.  My script uses vorbiscomment because the vorbis perl libraries that are available are too abstracted and only write lowercase tags.  Due to this it is possible it will encounter problems with particular invalid filenames when it performs shell calls.  This can’t be helped without further escaping.  In my case all my files are named sanely on purpose.  If this occurs it won’t destroy the file, it just won’t edit the tags. You can add more escape characters in the obvious place if you need.

You can find the script and more information about it here:  http://www.slowest.net/sansa/

Hope this helps!

Ryan

Hello, I have the same issue, but my clip’s hardware revision is 2…

This problem is supposed to be fixed in this hardware revision, but I just loaded some ogg files and it shows “unknown” for every tag…

I have read the firmware update thread for hw rev. 2 and it doesn’t say anything about this.

Please help.

Are you sure your ogg vorbis files have any tag information?  If there isn’t any Album, Artist or Title information in the file it is going to list it as unknown.  You should be able to see this information on your computer.  I just use ogginfo on my Linux box, but you should be able to use a program like easytag to see/edit this info.

Thanks for the reply. I just ran ogginfo on one of the files. Here’s the output:

Processing file "01 - Stella By Starlight.ogg"...  
  
Warning: Hole in data (4500 bytes) found at approximate offset 689315553491288064 bytes. Corrupted ogg.  
Warning: Hole in data (9000 bytes) found at approximate offset 689315553491288064 bytes. Corrupted ogg.  
Warning: Hole in data (13500 bytes) found at approximate offset 689315553491288064 bytes. Corrupted ogg.  
New logical stream (#1, serial: 1542d258): type vorbis  
Vorbis headers parsed for stream 1, information follows...  
Version: 0  
Vendor: Xiph.Org libVorbis I 20070622 (1.2.0)  
Channels: 2  
Rate: 44100  
  
Nominal bitrate: 192.000000 kb/s  
Upper bitrate not set  
Lower bitrate not set  
User comments section follows...  
 title=Stella By Starlight  
 artist=Tete Montoliu Trio  
 genre=8  
 date=1965  
 album=A Tot Jazz  
 tracknumber=01  
Vorbis stream 1:  
 Total data length: 13803026 bytes  
 Playback length: 9m:17.506s  
 Average bitrate: 198.067960 kb/s  
Logical stream 1 ended  
Warning: Hole in data (13807744 bytes) found at approximate offset 689315553491288064 bytes. Corrupted ogg.

 Looks like the tags are there, but I got corrupted files. The files were encoded with Grip using oggenc.

Any more info on this will be gratly appreciated. Thanks!

 EDIT: I just tried loading some more files (the tags where UPPERCASE) and it seems to be working fine. I don’t know if the Clip was unable to read the tag data because of the corrupted ogg file or because of the lowercase tags. I will try with some more filesand let you know.

Message Edited by oblivious on 02-05-2009 09:32 PM

There used to be a problem with the Clip not displaying ogg vorbis tags that were lower case.  This should have been fixed in the latest firmware.  Make sure your Clip is runing version 2.01.16.

Problem solved. I used Grip to create the ogg files (via oggenc). There are checkboxes in Grip to add ID3 and/or ID2 tags to encoded files. Turns out this is NOT good for ogg files. I unchecked the boxes and the resulting files (with lowercase tags) are no longer corrupted and display correctly on the Clip!

Yeah, currently only Vorbis Comment style tags are supported for Ogg and FLAC, as this is the standard tag type for these formats.  Sandisk has said ID3 support will be added for Ogg/FLAC in an upcoming FW.

Were not planning to add ID3 tag support for OGG/ FLAC at this time.

We support Vorbis Comments.

Whoops, sorry.  I thought I remember a post about this issue that said you were looking at it.

Honestly thought, I don’t really see a problem with it as Voris Comments are the standard/preferred tag type for these formats.

I ran into same problem Unknown while using ogg files.

i use db poweramp ripper

i create a profile to rip and use this naming string saved in my profile to get clip to see folder and such

so far no problems i just took default nameing string and capatilized what u se capitalized here

original string

[IFVALUE]album artist,[album artist],[IFCOMP]Various Artists[][IF!COMP][artist][][][album][track] [artist] - [title]

modified string

[IFVALUE]ALBUM ARTIST,[ALBUM ARTIST],[IFCOMP]Various Artists[][IF!COMP][ARTIST][][][ALBUM][TRACK] [ARTIST] - [title]