Sansa 8GB screen goes black

Hey guys,

             My Fuze is about 3 weeks old, and worked fine till yesterday. It was being charged and at the same time downloading the new Sansa Media Converter, where i eventually cancelled the download. This morning, when i tried using my player, everytime i touch the wheel or the home button, the screen goes black for a few seconds then comes back. I tried re-installing old and new firmware, but nothing has changed.

Now, i purchased this fuze when i was in Dubai for vacation, and now i am in Germany. If i would need to send the device to Sansa in Europe, would they accept the reciept with out any problems and without the original packaging?

Is there anything i can try first? any tips before sending this out?

Is there a Sansa center in Germany? if so, can anyone be kind enough to inform me how to contact them (by mail if possible).

Thanks guys, but i am really pissed off…i was really liking this player, hate it when things like this happen…

First have you tried resetting the fuze.

Second how did you install the firmware.



      Followed everything the stickies here on the forum, step by step…

Still the same problem, and i contacted Sansa Germany via email, no reply in 3 days. I will be calling them Monday, let’s see


          There is definately something up with the battery, here is why:

  • When the Fuze is fully charged, and i switch it on, the battery shows 80% full.

  • Only when the battery is “full” does the screen act up when i press any button, but the blue ring light still works.

  • When the battery is 10% or lower (shows red instead of green), the screen works perfectly fine, but the blue ring light doesn’t work.

Does this new info help in anyway?

Got an email from Sandisk Germany, they asked me to set the Fuze in MCS mode, and manually upgrade the firmware again. It also stated in the email, that this should get the Fuze back to working normally.

Thing is, i already tried this and it did not work, before i contacted them.

I did it anyways, and still the same problem is there.

Replied to them, told them what i am telling you guys…

So far, it is a very slow progress, if you call it progress…

Hi I have exactly same problem, did you resolve the problem in the end? 

My screen goes black when using wheel and battery fully charged.