Sandisk Ultra 3.0 USB stick - painfully slow transfer speeds

Hi all,

I own the SANDISK ULTRA FLAIR USB 3.0 FLASH DRIVE, 64 gb one. 

The transfer speeds on this thing are painfully slow. My desktop PC is an i5 650 running at 3.2 Gz, with 1.5gb gddr5 RAM, Win 7, as I mostly just use it for work in MS Office and emails. 

I’ve enabled the “better performance” option already through the ‘policies’ tab and there’s literally nothing running in the background - still the transfer speeds kick off at around 60mb/s but barely stay there for 5-10 seconds - and gradually crawl down to 3.5mb/s! It just keeps slowing down more and more and, say, an 8.5gb file, takes nearly 40 minutes to transfer. 

All the USB ports I’ve tried yield the same result and they are all USB 3.0. It’s a Lenovo ThinkCentre desktop PC. 

What’s wrong here? I used to have a P4 with barely 1 gig RAM and Win XP two years ago and file transfers were much faster than this. 

Please help! I don’t think its normal to have such abysmal transfer speeds with my USB stick and system specs. 

Are you writing to the SecureAccess vault???

^^ Huh? I don’t even know what your comment means. 

I’m just transferring large video files from my HDD to the USB stick. 

SanDisk USB drives come with a built in security app call Secure Access.  If your’s didn’t come with it it’s probably a counterfeit.  If you formated the drive when you bought it you may have ruined the factory’s block alignment.  Either situation can cause your problem.

Well, this security app thing was mentioned on the packaging but there was nothing on the flash drive itself. 

I have formatted it now and then - could it be the ntfs file system that’s causing the slowdown? The drive works great - my only issue is the painfully slow write speeds. 

Should I try exFAT now?

exFAT is indeed the better choice and the format used when they are manufactured.  If the drive had no SecureAccess files and folders on it when you bought it it was used or is a counterfeit.

And that means what exactly? that it will not provide the correct write speeds? 

It also gets very hot I’ve noticed - after being hooked into my PC or Xbox for even 5 mins, with the aircon turned on. Is this normal?

Plus, I find it extremely odd that the transfer starts off at just above 60 mb/s and within seconds, comes down to somewhere between 3-4 mb/s. 

Let us know how it works when you format it back to how the factory built it.

Your feedback doesn’t help, sorry. Formatted it to NTFS and hasn’t made much of an impact. Transfers start at around 60-70mb/s, and gradually takes a few minutes to come down to 4.5 or 5mb/s. A 10gb video file still takes 35-40 mins to transfer!

Format it to the factory format, exFAT.